Closed Bug 1696942 Opened 1 year ago Closed 1 year ago

The preloaded new tab page is repainted whenever the browser window is resized or (de)activated

Categories

(Firefox :: New Tab Page, defect)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1548683

People

(Reporter: florian, Unassigned)

Details

(Keywords: power, Whiteboard: [fxperf])

Here is a profile of resizing a browser window and then deactivating and reactivating the window twice: https://share.firefox.dev/3c71ZO8

There's a lot of activity in the Privileged Content process that restyles/reflows/repaints an about:newtab page for all resize activate/deactivate event the parent process receives.

From the Browser Toolbox, if I execute gBrowser.preloadedBrowser.hidden = true then the Privileged Content process remains quiet when I resize the browser window.

See Also: → 1548683
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1548683
See Also: 1548683
You need to log in before you can comment on or make changes to this bug.