Closed Bug 1697083 Opened 7 months ago Closed 6 months ago

Help > Troubleshoot Mode should end with an ellipsis

Categories

(Firefox :: Menus, defect, P5)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
88 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox86 --- unaffected
firefox87 --- unaffected
firefox88 --- verified

People

(Reporter: yoasif, Assigned: mconley)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: nightly-community, regression)

Attachments

(2 files)

The ellipsis is used in Firefox to indicate that additional user input is needed. Currently, the menu item here does not have one.

Steps to reproduce:

  1. Set browser.proton.enabled to true
  2. Restart Firefox
  3. Click app menu
  4. Click Help
  5. Select "Troubleshoot Mode"

What happens:

Observe that "Troubleshoot Mode" appears with a modal dialog, requiring user input.

Expected result:

Since the menu item opens a dialog that requires user input, the menu item should have an ellipsis.

Some guidelines:

https://developer.apple.com/design/human-interface-guidelines/macos/menus/menu-anatomy/

Use an ellipsis whenever choosing a menu item requires additional input from the user. The ellipsis character (…) means a dialog or separate window will open and prompt the user for additional information or to make a choice.

https://docs.microsoft.com/en-us/previous-versions/windows/desktop/bb246448(v=vs.85)

Include an ellipsis (...) at the end of a menu command that opens another dialog box rather than immediately performing an action. The ellipsis is a visual cue that the user must supply additional information to complete the command.

Has STR: --- → yes

:yoasif, if you think that's a regression, could you try to find a regression range using for example mozregression?

Mike, was there a conscious decision not to include the ellipsis here?

Severity: -- → S4
Flags: needinfo?(mconley)
OS: Unspecified → All
Priority: -- → P5
Regressed by: 1693092
Hardware: Unspecified → Desktop

Set release status flags based on info from the regressing bug 1693092

I spoke to Meridel - she agrees we need an ellipsis here. Hey flod, when we add punctuation like this, can I presume that we need to rev the string ID as well?

Flags: needinfo?(mconley) → needinfo?(francesco.lodolo)
Assignee: nobody → mconley
Status: NEW → ASSIGNED

(In reply to Mike Conley (:mconley) (:⚙️) (Catching up on needinfos) from comment #5)

I spoke to Meridel - she agrees we need an ellipsis here. Hey flod, when we add punctuation like this, can I presume that we need to rev the string ID as well?

Sadly, yes. And we can't even add it in a migration, because some locales might not use the same ellipsis character.

Flags: needinfo?(francesco.lodolo)
Pushed by flodolo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6271c891f1ed
Troubleshoot Mode menu item should have an ellipsis. r=flod,fluent-reviewers
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 88 Branch
Flags: qe-verify+

Verified - Fixed in latest Nightly 89.0a1 (build id: 20210331215444), Beta 87.0b5 and Release version 87, using Windows 10, MacOS 11 and Ubuntu 18.04.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.