If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

No mouse move events while dragging on an image

VERIFIED DUPLICATE of bug 114852

Status

()

Core
DOM: Events
VERIFIED DUPLICATE of bug 114852
15 years ago
15 years ago

People

(Reporter: Fjord Lynn, Assigned: joki (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

In the page at http://lynnsoft.2y.net:81/mozerr/err2.html you can see when you
move the mouse over the image, the coordinates in the status at the bottom are
updates. When you press the mouse down and them move the mouse (dragging), the
status no longer is updated as there are no mouse move events. It is impossible
to tell if the mouse has moved while the button is down.

Reproducible: Always

Steps to Reproduce:
1. go to http://lynnsoft.2y.net:81/mozerr/err2.html
2. put the mouse over the image
3. click and hold the left button
4. move the mouse while holding the button

Actual Results:  
The cursor turns into a "no" symbol and the coordinates at the bottom remain at
the poitn where the mouse went down

Expected Results:  
The coordinates should keep updating because of mouse move events being sent

Comment 1

15 years ago
Add 
onmousedown="return false;"
to the image and the problem will be solved.

See
Bug 114852, comment 9.

INVALID?

*** This bug has been marked as a duplicate of 114852 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.