If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Cycling through form fields skips password fields

VERIFIED WORKSFORME

Status

()

Core
Layout: Form Controls
--
major
VERIFIED WORKSFORME
15 years ago
14 years ago

People

(Reporter: Erich 'Ricky' Iseli, Unassigned)

Tracking

({regression})

Trunk
x86
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
Testing: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.1) Gecko/20020919

To reproduce, make sure you are not logged in in your bugzilla account or find
any other page with at least 3 form fields, of which one is a password field.

Steps to reproduce

1) Go to the login page of bugzilla
http://bugzilla.mozilla.org/enter_bug.cgi?product=Phoenix
2) focus the e-mail field
3) press tab

=> Result: focus jumps to "forgotten password" field
=> Expected result: focus jumps to next field, that is, the "password" field

Comment 1

15 years ago
unable to reproduce with a phoenix build from this afternoon on windows or
linux. Erich, these bugs sound like Mozilla bugs and not Phoenix bugs. If you
can reproduce the problem in Mozilla then please file it there and not here. Thanks.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

15 years ago
Yep, you're right, I tested it with 1.1 but not the latest nightly to find out
if it's a Mozilla bug. Indeed a Mozilla bug. Changing product and reopening
after testing it in the latest mozilla nightly. Marking as regression. Since
it's highly visible, increasing severity.
Severity: normal → major
Status: RESOLVED → REOPENED
Component: General → HTML Form Controls
Keywords: regression
Product: Phoenix → Browser
Resolution: WORKSFORME → ---
Version: unspecified → other

Comment 3

15 years ago
reassign
Assignee: blaker → jkeiser
Status: REOPENED → NEW
QA Contact: asa → tpreston
(Reporter)

Comment 4

15 years ago
On a sidenote: is it a feature or a bug that it only cycles through form-fields
instead of also cycling through links?

Comment 5

15 years ago
This looks like it's fixed.  Can you retest?

Comment 6

15 years ago
-> triage bin
Assignee: jkeiser → form
Worskforme as well.  Marking so, due to lack of response.
Status: NEW → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

14 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.