Closed Bug 1697467 Opened 5 months ago Closed 5 months ago

Non-native theme button/dropdown menu are not visible with high contrast

Categories

(Core :: Widget, defect)

Desktop
Windows 10
defect

Tracking

()

VERIFIED FIXED
88 Branch
Tracking Status
firefox88 --- verified

People

(Reporter: Gabi, Assigned: emilio)

References

(Blocks 1 open bug)

Details

Attachments

(4 files)

Attached file test.html

Affected versions

  • Nightly 88.0a1

Affected platforms

  • Windows 10x64

Steps to reproduce

  1. Launch Firefox Nightly
  2. Enable high contrast mode (Alt+Shift+PtrScr)
  3. Go to test.html link
  4. Observe the button form control

Expected result

  • Button form control is visible with high contrast mode

Actual result

  • Button form control is not visible with high contrast

Regression range
Not a regression

Additional notes

  • Button/dropdowns are visible when setting pref "widget.non-native-theme.enabled" = false
  • https://www.groupon.com dropdown menus are not visible with high contrast
Has STR: --- → yes
Assignee: nobody → emilio

Linux can also have high contrast (and mac, if you tweak prefs, but
let's assume that doesn't happen), so no reason we shouldn't share this
code.

One related simplification while I was doing this code move is that I
managed to remove the scrollbar "border" code. Turns out that Windows
was overriding ComputeScrollbarColors so that border and track colors
were always the same, and Linux was ignoring the border anyways, so with
this we can simplfiy the implementation a bit (as the Linux scrollbar
track / corner code can be shared with Windows now).

As in that case we will actually use system colors.

Depends on D107863

Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/483806cf81ce
Push the high contrast code from nsNativeBasicThemeWin to nsNativeBasicTheme. r=mstange
https://hg.mozilla.org/integration/autoland/rev/d465f635cd83
Don't use standins for non native theme when the document uses high contrast. r=mstange
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/autoland/rev/f5231f80b867
Fix a typo, I don't know how to boolean.

Verified as fixed with Nightly 88.0a1 on Windows 10x64.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.