Border affects paragraph margin in list item

RESOLVED FIXED

Status

()

Core
Layout: Block and Inline
--
minor
RESOLVED FIXED
15 years ago
11 years ago

People

(Reporter: Matt McClanahan, Unassigned)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

15 years ago
In paragraph-list.html, the last list item's bullet is rendered above where it
should be.  I'm able to fix it by setting the margin-top of the first paragraph
in the list item to 0px.  However this only works if the list item has a border
on its top edge (the second list item).

This is only an issue for the list items which have <a name>'s in them (The
second and fourth).

Testing with Mozilla 1.0 (via Galeon) and 1.2a.

Comment 1

15 years ago
Created attachment 99871 [details]
More testcases

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase

Comment 2

15 years ago
*** Bug 175486 has been marked as a duplicate of this bug. ***

Updated

15 years ago
OS: Linux → All

Updated

15 years ago
Priority: -- → P3
Target Milestone: --- → Future
Is this still a problem?

Comment 4

15 years ago
It's better, but still not according to spec AFAICT:
http://www.w3.org/TR/css3-lists/#markers
"Thus, markers are aligned with the first line of an element's content"
Severity: normal → minor

Comment 5

15 years ago
Created attachment 122225 [details]
Testcase #2, bullet should align with "P" in all cases
Attachment #99871 - Attachment is obsolete: true
.
Assignee: attinasi → block-and-inline
Component: Layout → Layout: Block & Inline
Priority: P3 → --
QA Contact: cpetersen0953 → ian
Target Milestone: Future → ---

Comment 7

11 years ago
A real life example for this can be seen in the right coloumn of this page
http://userpage.fu-berlin.de/~frers/cgi-bin/blosxom.cgi
This bug appears with current trunk builds of Firefox and Camino too.

Comment 8

11 years ago
With the checkin of bug 300030 (Refactor intrinsic width computation out of nsIFrame::Reflow) this bug seems to be resolved. :) Yay and thanks!
No, attachment 122225 [details] is still broken (the issue there is the vertical position of the bullets in the right column).

Comment 10

11 years ago
(In reply to comment #5)
> Created an attachment (id=122225) [details]
> Testcase #2, bullet should align with "P" in all cases

WFM, if I understand this correctly
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a3pre) Gecko/20070227 Minefield/3.0a3pre 

Created attachment 256941 [details] [diff] [review]
Regression tests
Fixed by checkin for bug 367332.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Depends on: 367332
Resolution: --- → FIXED
Added the tests.
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.