mousedown in browser stall/freezes active download

RESOLVED FIXED in Camino0.9

Status

Camino Graveyard
Downloading
P3
normal
RESOLVED FIXED
16 years ago
13 years ago

People

(Reporter: bugzilla, Assigned: Simon Fraser)

Tracking

unspecified
Camino0.9
PowerPC
Mac OS X

Details

(Reporter)

Description

16 years ago
noticed this one today in buildid: 2002091305 w/favicon.ico enabled and the
onload noaccess for referrer tags.  haven't seen it elsewhere so here's my report.
 
went to versiontracker.com, started downloading stuffit 7 (4.3MB) and have the
progress window at the bottom where it's progress indicator is visible when
focus is back on the main window.  click/hold the vertical scroll widget and
continue moving down the page... lo and behold the download stalls completely
waiting for mouse release to continue and continues fine afterwards until next
time mouse is held down.  obviously works best with large files that aren't
already cached so you have time to start the d/l, move the progress window into
a visible spot, back to main window and then grab the scroll widget.

if this was os 9 I could understand, but OSX 10.1.5?  frozen downloads make the
baby jesus cry!

Comment 1

16 years ago
bugzilla@goatcam.net, what build ID are you reporting this bug against?
don't think there's much we can do about this. the timer that polls the PLEvent
queue doesn't fire when tracking a scrollbar because it's on the same UI thread
as cocoa.

i'm pretty sure the data is still being downloaded since it's off on other
threads. simon? thoughts?
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → Future
(Assignee)

Comment 3

16 years ago
here's where we're blocked:

          500 main
            500 NSApplicationMain
              500 -[NSApplication run]
                343 -[NSApplication sendEvent:]
                  343 -[BrowserWindow sendEvent:]
                    343 -[NSWindow sendEvent:]
                      339 -[NSScroller mouseDown:]
                        338 -[NSScroller trackKnob:]
                          338 -[NSApplication
nextEventMatchingMask:untilDate:inMode:dequeue:]
                            338 _DPSNextEvent
                              338 BlockUntilNextEventMatchingListInMode
                                338 ReceiveNextEventCommon
                                  338 RunCurrentEventLoopInMode
                                    338 CFRunLoopRunSpecific
                                      338 __CFRunLoopRun
                                        338 mach_msg
                                          338 mach_msg_trap
                                            338 mach_msg_trap [STACK TOP]


The scrollbar code runs a modal event loop. We'd have to hook our timer onto
this to get it to fire.

Comment 4

15 years ago
This bug is still present in the 20030902 NB.

Comment 5

15 years ago
Can anyone still reproduce this with the latest NB using the new DL manager ?

Comment 6

15 years ago
Using 10.3 and the 20040101 NB. I hadthe followimng behaiour.

I started a 1.2 MB download and followed the instructions. When I clcik and hold
on the main window scroolbar the progress indicator doesn't go further but as
soon as I releas it it slides further at a greater speed indicating that data
was still getting in but that the GUI was temporarily not going further. 

Looks Like Mike is right in Comment #2.

Comment 7

15 years ago
I can't reproduce this with a build from 2003123015 and Mac OS X 10.3.2. Jasper
- can you provide a more detailed description of how you're reproducing it?

Comment 8

15 years ago
1) start a download
2) dl window opens
3) dl starts
4) go back to the main window (browser)
5) click and hold it's scroll bar while watching the progress bar in the dl manager.
6) when holding the scroll bar for a long time and releasing it, the progress
bar jumps further. Just wathc it and you will know what I mean.
Interestingly, in 20050419 (0.8+), the progress bar continues to update; only
the text (xx MB of yy) doesn't update.
(Assignee)

Updated

13 years ago
Assignee: pinkerton → sfraser_bugs
Status: ASSIGNED → NEW
(Assignee)

Comment 10

13 years ago
Fixed by adding the timer to the NSEventTrackingRunLoopMode.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Priority: -- → P3
Resolution: --- → FIXED
Target Milestone: Future → Camino0.9
You need to log in before you can comment on or make changes to this bug.