Closed Bug 1698492 Opened 6 months ago Closed 6 months ago

FxA Sync Now string is not updated accordingly while syncing

Categories

(Firefox :: Menus, defect)

Firefox 88
defect

Tracking

()

VERIFIED FIXED
88 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox86 --- disabled
firefox87 --- disabled
firefox88 --- verified

People

(Reporter: alin.ilea, Assigned: emalysz)

References

(Blocks 2 open bugs, Regression)

Details

(Keywords: regression, Whiteboard: [proton-hamburger-menu])

Attachments

(2 files)

Tested with:

Nightly 88.0a1 (2021-03-15)

Tested on:

Windows 10

Preconditions:

In about:config, set browser.proton.enabled = true

Steps:

  1. Launch Firefox Nightly and sign in to sync.
  2. Focus out the browser for 1-2 minutes.
  3. Open the FxA submenu.

Actual result:

The sync blue icon is displayed and rotates but the string is still "Sync Now" while syncing. (See the screen recording attached in comment 1).

Expected result:

Based on the documentation and on the comment.1 from bug 1694678, when syncing is in progress the string should be "Syncing...". When the string is "Sync Now" the blue sync icon should not be displayed.

This seems to be regressed by: https://bugzilla.mozilla.org/show_bug.cgi?id=1694678
@Emma, could you please take a look over this when you get a chance?

Flags: needinfo?(emalysz)
Severity: -- → S3
Attached video sync now issue.mp4
Assignee: nobody → emalysz
Status: NEW → ASSIGNED
Flags: needinfo?(emalysz)
Attachment #9209254 - Attachment description: Bug 1698492, synchronously update fxa sync now string to avoid timing errors → Bug 1698492, dynamically set data-l10n-id attribute for sync now buttons when panel views are showing
Pushed by emalysz@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/089aa761f9f7
dynamically set data-l10n-id attribute for sync now buttons when panel views are showing r=Gijs,fluent-reviewers
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 88 Branch
Regressions: 1700431
Flags: qe-verify+

Verified - Fixed in Beta 88.0b4 and latest Nightly 89.0a1 (2021-03-28), using Windows 10, Ubuntu 18.04 and MacOS 10.15.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.