Multipart related messages are duplicating body text

VERIFIED FIXED in M11

Status

MailNews Core
MIME
P3
normal
VERIFIED FIXED
18 years ago
9 years ago

People

(Reporter: rhp (gone), Assigned: rhp (gone))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

18 years ago
This is caused by the differences in behavior of nsString and nsCString. if you
do the following:

nsString me;

me.Append("this is a fun buffer", 0);

it will do the right thing and append nothing. BUT, an nsCString appends the
entire string.

It's an easy fix that I will attach to this bug report.

Scott, can you review it for me.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M11
(Assignee)

Comment 1

18 years ago
Created attachment 2330 [details] [diff] [review]
The fix

Comment 2

18 years ago
Hmm it confuses me since both nsCString and nsString share the same
implementation (as to why using one or the other would make a difference).

But your addition looks harmless so if it fixes something then I say go for it
=).

Comment 3

18 years ago
adding esther to cc: list.  Esther - this is what you were mentioning to me
today. No need to file a bug :-)
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

18 years ago
This should be all better now.

- rhp

Updated

18 years ago
QA Contact: lchiang → pmock

Comment 5

18 years ago
changing QA assigned to myself

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 6

18 years ago
Verified as fixed on win32, macos, and linux using the following builds:
ftp://sweetlou/products/client/seamonkey/windows/32bit/x86/1999-12-21-09-M13/sea
monkey32e.exe
ftp://sweetlou/products/client/seamonkey/unix/linux_glibc/2.2/x86/1999-12-21-08-
M13/netscape-i686-pc-linux-gnu.tar.gz
ftp://sweetlou/products/client/seamonkey/macos/8.x/ppc/1999-12-21-08-M13/NSMacIn
staller-M13.sea.bin

I tested using a multi-related mail message.  The text was not duplicated.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.