[ps] after some time, print command stops working

RESOLVED WORKSFORME

Status

()

Core
Printing: Output
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Bill Shannon, Assigned: rods (gone))

Tracking

Trunk
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
After some time, and many succesful prints, printing stops working,
complaining that there was an error sending commands to the printer.
As far as I can tell, it's not even invoking my print command when
it gets the error.

This is with Mozilla 1.1 on Solaris 8.

Comment 1

16 years ago
Reporter:
What is the _exact_ message returned by Mozilla ?
(Reporter)

Comment 2

16 years ago
The exact message is:

There was a problem printing.  An instruction that was sent to the printer failed.

This just happened while using the default print command.

Comment 3

16 years ago
Per mozilla/html/base/src/printing.properties this maps to the error code
|NS_ERROR_GFX_PRINTER_CMD_FAILURE| - which is used four times in
mozilla/gfx/src/ps/nsPostScriptObj.cpp (see
http://lxr.mozilla.org/seamonkey/ident?i=NS_ERROR_GFX_PRINTER_CMD_FAILURE).

Reporter:
Can you check whether a similar problem (e.g. can't print after printing
multiple times) occurs with the Xprint module, too ?

Updated

15 years ago
Summary: after some time, print command stops working → [ps] after some time, print command stops working

Comment 4

14 years ago
Reporter:
Can you check whether a similar problem (e.g. can't print after printing
multiple times) occurs with the Xprint module, too?
(Reporter)

Comment 5

14 years ago
I don't use Xprint, and since setup seems far from obvious, I'm not very
interested in trying it.

However, I haven't seen this problem in quite some time.  I believe it was
due to running out of file descriptors.  I think some other fix solved the
file descriptor bug, and I haven't seen this bug since then.

As far as I'm concerned, you can close this bug report.

Comment 6

14 years ago
Resolving per the previous comment. If anyone can reproduce this with a current
software release, please feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.