Closed Bug 1699558 Opened 6 months ago Closed 6 months ago

360° video on youtube has wrong colors

Categories

(Core :: Canvas: WebGL, defect)

Firefox 88
Unspecified
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 1678989
Tracking Status
firefox86 --- wontfix
firefox87 --- wontfix
firefox88 --- wontfix
firefox89 --- fixed

People

(Reporter: mkem, Unassigned)

References

(Regression)

Details

(Keywords: regression)

Attachments

(3 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:88.0) Gecko/20100101 Firefox/88.0

Steps to reproduce:

  1. Open 360° video located on this address: https://www.youtube.com/watch?v=h8VDCZlTTRQ

  2. Check produced colors on the video.

Actual results:

Colors of the video are wrong. I attached screenshot of video with wrong colors.

Expected results:

Colors of the video should be alright. I tested it also in Safari and colors are alright, so that I think something is wrong in Firefox.

I was able to find this bug https://bugzilla.mozilla.org/show_bug.cgi?id=1659760 which was resolved in the past. It had similar effect on colors of video as it is shown in attached screenshot. Could it be related to reported problem?

The Bugbug bot thinks this bug should belong to the 'Core::Audio/Video: Playback' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core
OS: Unspecified → macOS

Thanks for the report. Good catch on this looking similar to bug 1659760 -- it does appear to be a similar issue with incorrect color mapping.

Moving this to the gfx component based on previous cases. Gfx folks, please pass back to media if needed and NI me if doing so.

Blocks: gfx-triage
Component: Audio/Video: Playback → Graphics: WebRender
Component: Graphics: WebRender → Canvas: WebGL
QA Whiteboard: [qa-regression-triage]

Notes:

  • confirmed on macOS 10.15 as well;
  • severity-wise this might be set between S2-S3(feel free to re-adjust), since the issue appears to be limited to this format of video(s) as far as initial investigation;
  • gfx.webrender.all - set as false as default; setting it on true does not change, issue still manifesting;
  • there were some cases in which, the initial video was loaded and did not display anything until the adds were being played back(afterwards, they still shown the issue) so as far as verifying might want to skip adds and swap between this and another video to properly asses state.

Regression range:

Severity: -- → S3
Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
Ever confirmed: true
Regressed by: 1640607
No longer blocks: gfx-triage
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1678989
You need to log in before you can comment on or make changes to this bug.