Ctrl-Tab causes crash when page is still loading

RESOLVED DUPLICATE of bug 146255

Status

SeaMonkey
General
--
major
RESOLVED DUPLICATE of bug 146255
16 years ago
14 years ago

People

(Reporter: Asun, Assigned: asa)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
As the title says, happens to me on both Win2K and WinXP. Only on certain pages,
espn.com is one of them. I've sent several talkback, but can't remember the
numbers. I'm using build Gecko/20020826.

Comment 1

16 years ago
Reporter, please run ~/mozila/components/talkback.exe and post one of the
incident ID#'s in the bug. Thanks.
(Reporter)

Comment 2

16 years ago
Here is the one from WinXP:
TB10307797E

Comment 3

16 years ago
Looks like this one was fixed by bug 146255. Try a new build created after 9/9
and verify that the problem is indeed fixed. If you are able to crash a build
created after that fix was checked in then please reopen this bug. (If you can't
reproduce it with a later build please verify this bug. Thanks.)
 
For now this one is a dupe of 146255. 

Thanks for testing the Mozilla browser! 

Product ID  MozillaTrunk
Build ID 2002082611
Operating System Windows NT 5.1 build 2600
URL visited ebay.com
User Comments Ctrl-Tab while page is loading

Stack Trace
nsEventStateManager::IsIFrameDoc
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp, line 4824]
nsEventStateManager::ShiftFocusByDoc
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp, line 5076]
nsEventStateManager::PostHandleEvent
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp, line 1905]
PresShell::HandleEventInternal
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6129]
PresShell::HandleEvent
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6031]
nsViewManager::HandleEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 2052]
nsView::HandleEvent [c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 306]
nsViewManager::DispatchEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 1909]
HandleEvent [c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 83]
nsWindow::DispatchEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1038]
nsWindow::DispatchWindowEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1055]
nsWindow::DispatchKeyEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 2886]
nsWindow::OnKeyDown
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 2975]
nsWindow::ProcessMessage
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 3800]
nsWindow::WindowProc
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1304]
USER32.dll + 0x3a5f (0x77d43a5f)
USER32.dll + 0x3b2e (0x77d43b2e)
USER32.dll + 0x3d6a (0x77d43d6a)
USER32.dll + 0x41fd (0x77d441fd)
nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp, line 452]
main1 [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1534]
main [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1881]
WinMain [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1899]
WinMainCRTStartup()
kernel32.dll + 0x1eb69 (0x77e7eb69)

*** This bug has been marked as a duplicate of 146255 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

16 years ago
I'll check whenever I have a chance to boot into Windows.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.