View|Sort|by * does not work on some attributes

VERIFIED FIXED in M18

Status

defect
P3
normal
VERIFIED FIXED
20 years ago
11 years ago

People

(Reporter: fenella, Assigned: scottputterman)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+] HAVE FIX)

(Reporter)

Description

20 years ago
This bug is used to track implementation of the View|Sort|by * features.
Features NOT implemented include:
by Flag
by Priority
by Size
by Thread
by Unread
by Order Received

Please let me know if I need separate bugs for each option.

Updated

20 years ago
Assignee: phil → putterman
(Reporter)

Updated

20 years ago
QA Contact: lchiang → fenella

Updated

20 years ago
Target Milestone: M12

Comment 1

20 years ago
M12
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
Target Milestone: M12 → M14

Comment 2

20 years ago
Sorting on the attributes which are critical for B1 does work, so this doesn't
seem like a B1 stopper.
Summary: [FEATURE] View|Sort|by * does not work → [FEATURE] View|Sort|by * does not work on some attributes
Target Milestone: M14 → M15
(Assignee)

Updated

19 years ago
Target Milestone: M15 → M16

Comment 3

19 years ago
Which of these are still broken on the tip?  Clicking the column headers and
using the menu "seem" to work in M15.  Is it that they're not sorting correctly?

Marking M17.  Move it back if there's some egregious problem here.
Target Milestone: M16 → M17

Comment 4

19 years ago
Fenella is talking about the menu items, I believe, Steve.

Comment 5

19 years ago
*** Bug 34831 has been marked as a duplicate of this bug. ***

Comment 6

19 years ago
[FEATURE] bugs past M16 are OUT for this release.  Marking M20.  If you disagree 
with this action, please help me explain it to the PDT.
Target Milestone: M17 → M20

Comment 7

19 years ago
If we are not going to be able to sort by these items, we need to take them out 
of the menu.  

I'd love to sort by unread though :-(
(Assignee)

Comment 8

19 years ago
As I've been mentioning in many other bugs, I'm not sure why we couldn't fix 
these after M16.  The word "Feature" runs a wide spectrum of meanings and this 
is on the end where it's basically a bug.
Target Milestone: M20 → M17
(Assignee)

Comment 9

19 years ago
these are just bugs. removing feature.
Summary: [FEATURE] View|Sort|by * does not work on some attributes → View|Sort|by * does not work on some attributes
(Assignee)

Comment 10

19 years ago
moving to M18 and nominating for beta3.
Keywords: nsbeta3
Target Milestone: M17 → M18
(Assignee)

Updated

19 years ago
Keywords: mail1

Comment 11

19 years ago
+ per mail triage to remove menu items that don't work.
Whiteboard: [nsbeta3+]
(Assignee)

Updated

19 years ago
Whiteboard: [nsbeta3+] → [nsbeta3+] HAVE FIX
(Assignee)

Comment 12

19 years ago
I have a fix for the original bug to make the flagged and unread columns sort.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 13

19 years ago
fix checked in.  sort by flag and unread column work.
(Reporter)

Comment 14

19 years ago
Linux (2000-08-16-09 M18)
Win32 (2000-08-16-10 M18)
Mac (2000-08-16-10 M18)
View|Sort|By Thread has been removed from the menu.
The rest are all working.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 15

19 years ago
Removing the mail1 keyword.
Keywords: mail1
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.