Frame gets duplicated as you click on "Market Tools" links

VERIFIED WORKSFORME

Status

()

Core
Embedding: APIs
P1
major
VERIFIED WORKSFORME
20 years ago
17 years ago

People

(Reporter: rubydoo123, Assigned: Nisheeth Ranjan)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

20 years ago
Platform: tested on winNT 4.0, win98, win95
Build: 11/30/98
Application: devprev.zip -- using xpviewer mode
Expected reults: expected to see ticker tape remain constant and main body frame
update.

Steps to reproduce:
Go to the above mentioned website
Notice the ticker on the bottom of the window
Select any link from the left frame under Market tools
 - an additional ticker frame is displayed on the bottom of the window.
Minimize window and then maximize
 - window does not refresh correctly
Select additional options from Market tools area
 - for each selection an additional ticker line is displayed

Comment 1

20 years ago
Rick, is this still a valid bug for xpapps?  If not, who should get this?

Updated

20 years ago
Status: NEW → ASSIGNED

Comment 2

20 years ago
This is a WebShell bug related to frames...  Whenever a document with frames is
minimized, the netsted frames do not repaint correctly...

Comment 3

20 years ago
Setting all current Open Critical and Major to M3

Updated

19 years ago
Assignee: rpotts → nisheeth
Status: ASSIGNED → NEW

Comment 4

19 years ago
Re-assigned to nisheeth@netscape.com.

Nisheeth, you're the webshell dude. now.  Congratulations. :-)  rpotts says we
don't force child webshells to repaint when we're restoring a webshell from
being minimized.

Comment 5

19 years ago
per leger, assigning QA contacts to all open bugs without QA contacts according
to list at http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 6

19 years ago
Accepting bug...

Updated

19 years ago
QA Contact: 4110 → 4144

Comment 7

19 years ago
Reassigning qa contact to petersen@netscape.com

Updated

19 years ago
Target Milestone: M3 → M4

Comment 8

19 years ago
nisheeth is getting close, but too risky for m3. moving to m4
(Assignee)

Updated

19 years ago
Target Milestone: M4 → M5
(Assignee)

Comment 9

19 years ago
Moving bug to M5...
(Assignee)

Updated

19 years ago
Component: Compositor → Embedding APIs
(Assignee)

Comment 10

19 years ago
Setting component to embedding APIs.
(Assignee)

Comment 11

19 years ago
Moving bugs of lower priority to M6...
(Assignee)

Comment 12

19 years ago
Moving non-crashing layout and webshell component bugs to M8...

I already have enough blockers and crashers for M6.  If I fix them in time for
M6, I'll move some of these bugs back to the M6 milestone.

I'm keeping the M7 milestone for fixing XML bugs.
(Assignee)

Updated

19 years ago
Summary: window does not refresh after selection → Frame gets duplicated as you click on "Market Tools" links
Target Milestone: M8 → M11
(Assignee)

Comment 13

19 years ago
Frames are getting repainted fine when the window is restored after
minimization.

The remaining problem is that the ticker tape gets duplicated as I click on the
links under "Market tools" links.  This seems to be a problem specific to this
page and hence lower priority.  I'll look into this for M11.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 14

19 years ago
I went to this this site and they no longer have a ticker tape on the bottom.
Marking bug WORKSFORME.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 15

19 years ago
With the latest build (sept 23rd), the page renders fine.
You need to log in before you can comment on or make changes to this bug.