Status

defect
P2
normal
VERIFIED FIXED
20 years ago
11 years ago

People

(Reporter: fenella, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+][5/16]3 days)

(Reporter)

Description

20 years ago
This bug is used to track implementation of the View|Headers|* features
including:
View Headers|All
View Headers|Normal
View Headers|Brief

Please advise if separate bugs need to be filed.
(Reporter)

Updated

20 years ago
QA Contact: lchiang → fenella

Updated

20 years ago
Assignee: phil → rhp

Comment 1

20 years ago
Reassign to rhp

Updated

20 years ago
Status: NEW → ASSIGNED
Target Milestone: M11

Updated

20 years ago
Target Milestone: M11 → M13

Comment 2

20 years ago
Feature work...moving out.

- rhp

Updated

20 years ago
Target Milestone: M13 → M15

Comment 3

20 years ago
*** Bug 23126 has been marked as a duplicate of this bug. ***

Comment 4

20 years ago
Bug 23126 notes that Organization isn't shown in the current header view, and it
is shown in the 4.x Normal view. Perhaps more importantly, Reply-To isn't shown
in the current header view, and we really need that.

Comment 5

20 years ago
Hi Scott,
I made sure that the UI is hooked up for this menu item. When you select 
different display options, you get a reload and the "mail.header_display" pref 
is set accordingly. The headers that are displayed in the body of mail messages 
(i.e. when forwarded or quoted) are observing this pref also.

There is a routine in nsMimeEmitterUtils.cpp called:

    EmitThisHeaderForPrefSetting(PRInt32 dispType, const char *header)

which could help you in tweaking the envelope UI, but I'm not sure.

Let me know if you need any help with this one.

- rhp
Assignee: rhp → mscott
Status: ASSIGNED → NEW

Comment 6

19 years ago
Hi:
      Am using M13, Win 98, PC (obviously). Can't get any of the headers beyond 
the default ones (Subject, From, Date, To) to display. Going to the view menu 
and choosing the different View Headers options has no effect whatsoever. 
Choosing view page source doesn't work either. Is there any way to get all the 
headers?
(Assignee)

Comment 7

19 years ago
Sorry, we haven't implemented view all headers yet. Look for it after beta 1.

Comment 8

19 years ago
*** Bug 29958 has been marked as a duplicate of this bug. ***

Comment 9

19 years ago
*** Bug 30619 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Whiteboard: 3 days

Comment 10

19 years ago
Syncing priority with marketing.  Moving to P2 to connote "In" for beta2.
Priority: P3 → P2

Comment 11

19 years ago
move to M16.  Not M15 stoppers
Target Milestone: M15 → M16

Comment 12

19 years ago
Also see bug #23365...???
(Assignee)

Comment 13

19 years ago
*** Bug 36441 has been marked as a duplicate of this bug. ***
The dup bug was nsbeta2+.
Keywords: nsbeta2

Comment 15

19 years ago
Putting on [nsbeta2+][5/16] radar.  
Whiteboard: 3 days → [nsbeta2+][5/16]3 days
(Assignee)

Comment 16

19 years ago
I've implemented the first part of this feature. If you click on a header name 
in the message pane (like From, To, cc, etc.) you'll get a popup which shows you 
all the headers for the message.

I think this will be more useful than a full view headers implementation. You 
can quickly glance at all the headers without having them take up all the real 
estate.

Now, I need to try to implement view all headers mode where we show you all the 
headers as the normal view in the message pane.
(Assignee)

Comment 17

19 years ago
Okay I actually finished this with a few minutes to spare b4 the deadline 
tonight. You can go to the View --> Headers menu item and choose All or Normal. 

Several caveats:
1) There is no brief mode. I didn't know what headers should go in a brief mode
2) there is no attachment menu when in view all headers mode.
3) this is no toggle icon to switch between a long and short view of email 
addresses. You only get the long view. 

And of course, in view normal mode you can now click on a header name like 
"From" and you'll get a popup containing all the headers. 

I'll file bugs on some of the caveats tomorrow.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 18

19 years ago
Scott - what happens if the user has the mode set to brief in 4.x and then 
migrates.  How do we interpret that setting in Netscape 6?  Thanks.
(Assignee)

Comment 19

19 years ago
brief == normal in that case.
BTW: If the collapsed/expanded state of the normal header view parts would stick
between sessions, we wouldn't need brief headers, would we?
The user could just collapse everything but the subject/from/date part and would
virtually have the 4.x brief mode. (OK, the date is not so nice.)
(Reporter)

Comment 21

19 years ago
Refer to Scott 5/16 comments:
See bug 39679. No attachment button in View All Headers mode 
Mark this one verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.