Closed Bug 1700129 Opened 10 months ago Closed 6 months ago

Add Context Search function to Firefox

Categories

(Firefox :: Search, enhancement)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1136131

People

(Reporter: worcester12345, Unassigned)

Details

(Keywords: helpwanted)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:87.0) Gecko/20100101 Firefox/87.0

Steps to reproduce:

Try to use Context Search function

Actual results:

Does not work (programming changes broke the ContextSearch extension)

Expected results:

Search by clicking on a word, and pop up your choice of search engines.

Would like to see the addon creators of the two ContextSearch versions be able to start adding their code directly to Firefox.

This can be the main bug for that, and separate smaller bugs can be marked as blocking this one as different parts of code are worked on or are being added.

Thank you.

Flags: needinfo?(olivier.debroqueville)
Flags: needinfo?(bugzilla)
Keywords: helpwanted
Flags: needinfo?(bugzilla)

The Bugbug bot thinks this bug should belong to the 'WebExtensions::Untriaged' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Product: Firefox → WebExtensions

I decided some time ago to stop using Firefox and to cease participation in Firefox add-on development, so please leave me out of the discussion.

You can do what you want with my source code (it's available and MPL tri-licenced), but a direct in-browser solution could likely be much more functional and elegant than my add-on code ever could.

The Swift Selection Search add-on works flawlessly for me.

https://addons.mozilla.org/en-CA/firefox/addon/swift-selection-search/

I have also stopped using Firefox and no longer wish to participate in Firefox add-on development.

I am willing to sell the extension source code and all rights on the extension to Mozilla for a reasonable fee to make up for all the time that went into developing the extension.

Flags: needinfo?(olivier.debroqueville)

Hello,

I could not reproduce the issue on the latest Nightly (89.0a1/20210323094659), Beta (88.0b2/20210323190052) or Release (87.0/20210318103112) under Windows 10 x64 and Ubuntu 16.04 LTS.

Tested with several extensions (Context Search, Swift Selection Search, ContextSearch web-ext, Simple Context Search) and all work fine.

(In reply to Alex Cornestean from comment #6)

Hello,

I could not reproduce the issue on the latest Nightly (89.0a1/20210323094659), Beta (88.0b2/20210323190052) or Release (87.0/20210318103112) under Windows 10 x64 and Ubuntu 16.04 LTS.

Tested with several extensions (Context Search, Swift Selection Search, ContextSearch web-ext, Simple Context Search) and all work fine.

This bug is NOT about running the extension(s) in Firefox. This bug is about putting that functionality into Firefox itself.
Thank you.

feature request for firefox

Type: defect → enhancement
Product: WebExtensions → Firefox
Status: UNCONFIRMED → NEW
Component: Untriaged → General
Ever confirmed: true
Product: Firefox → WebExtensions
Version: Firefox 87 → Trunk

As I said last time, this is a feature request for firefox. Don't bounce it without explanation.

Component: General → Untriaged
Product: WebExtensions → Firefox

Changing Enhancement to Search component.
regards

Component: Untriaged → Search

For future bugs that are filed, it would be nice to have a description of the part(s) of the add-on that should be ported, or at least a description of what functionality is provided by the add-on that is desired.

That said, the add-on is providing access to all the search providers in the context menu, that makes this a duplicate of bug 1136131.

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1136131

(In reply to Ben Basson from comment #3)

I decided some time ago to stop using Firefox and to cease participation in Firefox add-on development, so please leave me out of the discussion.

You can do what you want with my source code (it's available and MPL tri-licenced), but a direct in-browser solution could likely be much more functional and elegant than my add-on code ever could.

Is that "source code" still around somewhere?

(In reply to Worcester12345 from comment #12)

(In reply to Ben Basson from comment #3)

I decided some time ago to stop using Firefox and to cease participation in Firefox add-on development, so please leave me out of the discussion.

You can do what you want with my source code (it's available and MPL tri-licenced), but a direct in-browser solution could likely be much more functional and elegant than my add-on code ever could.

Is that "source code" still around somewhere?

Looks like https://github.com/benbasson/contextsearch

You need to log in before you can comment on or make changes to this bug.