Chimera unexpectedly quit [@ GetPixBounds]

RESOLVED DUPLICATE of bug 167312

Status

--
critical
RESOLVED DUPLICATE of bug 167312
16 years ago
16 years ago

People

(Reporter: mozilla, Assigned: saari)

Tracking

({crash})

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Using Chimera 0.5, OS X 10.2.1.

No applications open other than Naxigator - view the web page
http://www.rolando.co.uk

Chimera generated the following Unexpect Quit error in the Console log.

**********

Date/Time:  2002-09-21 03:56:40 +0100
OS Version: 10.2.1 (Build 6D52)
Host:       Roland-iMac.local.

Command:    Navigator
PID:        1017

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

Thread 0 Crashed:
 #0   0x91a8d6b8 in GetPixBounds
 #1   0x92d04f60 in HideDragHilite
 #2   0x0042bc54 in Leave__19nsDragHelperServiceP13OpaqueDragRefP12nsIEventSink
 #3   0x00015e84 in -[CHBrowserView draggingExited:]
 #4   0x931704a0 in NSCoreDragTrackingProc
 #5   0x930074d8 in DoTrackingMessage
 #6   0x93010c74 in CoreDragMessageHandler
 #7   0x9016f8ac in __CFMessagePortPerform
 #8   0x9015c250 in __CFRunLoopDoSource1
 #9   0x90149354 in __CFRunLoopRun
 #10  0x9018157c in CFRunLoopRunSpecific
 #11  0x92ba34cc in RunCurrentEventLoopInMode
 #12  0x92bb32f4 in ReceiveNextEventCommon
 #13  0x92bda280 in BlockUntilNextEventMatchingListInMode
 #14  0x93082184 in _DPSNextEvent
 #15  0x930ccf84 in -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:]
 #16  0x930ca500 in -[NSApplication run]
 #17  0x930d2598 in NSApplicationMain
 #18  0x00005024 in main
 #19  0x00004ed4 in _start
 #20  0x00004d04 in start

Thread 1:
 #0   0x90025e8c in select
 #1   0x0101d804 in poll
 #2   0x01019ecc in _pr_poll_with_poll
 #3   0x0016a68c in Run__24nsSocketTransportService
 #4   0x050598f0 in Main__8nsThreadPv
 #5   0x0101b388 in _pt_root
 #6   0x90021428 in _pthread_body

Thread 2:
 #0   0x9003f188 in semaphore_wait_signal_trap
 #1   0x9003efa4 in _pthread_cond_wait
 #2   0x01016474 in PR_WaitCondVar
 #3   0x0014b2cc in DequeuePendingQ__12nsDNSService
 #4   0x0014acd4 in Run__12nsDNSService
 #5   0x050598f0 in Main__8nsThreadPv
 #6   0x0101b388 in _pt_root
 #7   0x90021428 in _pthread_body

Thread 3:
 #0   0x90042d68 in semaphore_timedwait_signal_trap
 #1   0x9003ef94 in _pthread_cond_wait
 #2   0x01016210 in pt_TimedWait
 #3   0x01016488 in PR_WaitCondVar
 #4   0x0505d38c in Run__11TimerThread
 #5   0x050598f0 in Main__8nsThreadPv
 #6   0x0101b388 in _pt_root
 #7   0x90021428 in _pthread_body

Thread 4:
 #0   0x9003f188 in semaphore_wait_signal_trap
 #1   0x9003efa4 in _pthread_cond_wait
 #2   0x01016474 in PR_WaitCondVar
 #3   0x0505aa2c in GetRequest__12nsThreadPoolP9nsIThread
 #4   0x0505b3a0 in Run__20nsThreadPoolRunnable
 #5   0x050598f0 in Main__8nsThreadPv
 #6   0x0101b388 in _pt_root
 #7   0x90021428 in _pthread_body

Thread 5:
 #0   0x9003f188 in semaphore_wait_signal_trap
 #1   0x9003efa4 in _pthread_cond_wait
 #2   0x90824180 in -[NSConditionLock lockWhenCondition:]
 #3   0x933515f4 in -[NSUIHeartBeat _heartBeatThread:]
 #4   0x9081cd38 in forkThreadForFunction
 #5   0x90021428 in _pthread_body

PPC Thread State:
  srr0: 0x91a8d6b8 srr1: 0x0000f030                vrsave: 0x00000000
   xer: 0x00000000   lr: 0x92d222c8  ctr: 0x91a8d6b8   mq: 0x00000000
    r0: 0x92d222c8   r1: 0xbfffeaa0   r2: 0x24002280   r3: 0x00000000
    r4: 0xbfffeae0   r5: 0x02907200   r6: 0x00000000   r7: 0xa1b1c1d3
    r8: 0x00000000   r9: 0xa0220eac  r10: 0x80000000  r11: 0xa2ba1edc
   r12: 0x91a8d6b8  r13: 0x00000000  r14: 0x00000000  r15: 0x00000001
   r16: 0x00000001  r17: 0x00000000  r18: 0x24002280  r19: 0x00000000
   r20: 0x00006e3f  r21: 0x00000000  r22: 0x0220bc10  r23: 0x00000004
   r24: 0x80000000  r25: 0x0255bbc8  r26: 0xbfffeb98  r27: 0x038ab610
   r28: 0x00000000  r29: 0x00ffb194  r30: 0x028a0da0  r31: 0x0042bb58
(Reporter)

Comment 1

16 years ago
Created attachment 100067 [details]
Console Report

Comment 2

16 years ago
Host www.rolando.co.uk could not be found using Chimera/2002091704.

Stack looks like bug 167312. Roland, can you still reproduce this problem using
a recent nightly build?
Severity: normal → critical
Keywords: crash
Summary: Unexpected Quit → Chimera unexpectedly quit [@ GetPixBounds]

Updated

16 years ago
Attachment #100067 - Attachment mime type: application/octet-stream → text/plain

Comment 3

16 years ago
Dup.

*** This bug has been marked as a duplicate of 167312 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Crash Signature: [@ GetPixBounds]
You need to log in before you can comment on or make changes to this bug.