Resizing a xul:tree (e.g. sidebar) scrolls to selected item

RESOLVED DUPLICATE of bug 454632

Status

()

Core
XUL
RESOLVED DUPLICATE of bug 454632
16 years ago
10 years ago

People

(Reporter: imran.geriskovan, Unassigned)

Tracking

(Blocks: 1 bug, {testcase})

Trunk
testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

2.45 KB, application/vnd.mozilla.xul+xml
Details
(Reporter)

Description

16 years ago
20020916
Resizing sidebar causes bookmarks pane to scroll to top.

Comment 1

16 years ago
Imran, please read the bug reporting guidelines 
(http://www.mozilla.org/quality/bug-writing-guidelines.html) before logging 
bugs.  We need steps to reproduce as well as expected behaviour.
(Reporter)

Comment 2

16 years ago
I thought it was self explanatory...
Anyway.. Here is the exact procedures to regenerate it:

1- Have bookmarks tab visible on sidebar.
2- Expand some folders so that there is some invisible items out of the visible
range.
3- Scroll down to some point so that there is invisible items at the top.
4- Resize sidebar.
5- See bookmarks tab scrolling to top automatically.

Is this ok?

Comment 3

16 years ago
Thanks Imran

This also occurs on the History tab
->Sidebar
Assignee: ben → sgehani
Component: Bookmarks → Sidebar
QA Contact: claudius → sujay
Summary: Resizing sidebar -> scroll bookmarks to top → Resizing sidebar scrolls Bookmarks/History to top

Comment 4

16 years ago
reporter (Imran): can you reproduce this bug with a recent build of mozilla (for
example, 1.2)? if so, please comment again with details. if not, please resolve
this bug as WORKSFORME. thanks.
(Reporter)

Comment 5

16 years ago
It is still the case for 20021108.
(Reporter)

Comment 6

16 years ago
and for 20021126
(Reporter)

Comment 7

16 years ago
Errr...
Now its behaviour is somewhat different.
It scrolls so that the selected folder/bookmark is positioned to top.

Comment 8

16 years ago
Imran, is it now behaving the way you expect? 
(Reporter)

Comment 9

16 years ago
20021209

Well if the selected (highlighted) folder is in visible range, it's fine.
However if it is outside the visible range, a "resize" again scrolls the sidebar.

Let me summarize my request:
The bookmarks should stay still whatever the action is. (ie sidebar resizing, etc..)

Comment 10

15 years ago
This is more extensive than just resizing the sidebar.  If you have a large
number of bookmarks, scroll to the bottom of them.  

1. If you resize the window, the scroll bar is reset to the top.
2. If you close the window (with F9 or View->Show->Sidebar) and then reopen it,
the scroll bar is reset to teh top.

Previous versions (I was previously on 1.2.1) did not do this.

I don't quite understand the "Version" tab above.  But I'm currently running
Mozilla 1.4 and have observed this.

Comment 11

15 years ago
Update summary because it (at least now) scrolls to the selected bookmark. So if
you haven't selected any yet, this is the first one.

I can reproduce this, and it's annoying if you have a buch of bookmarks.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Resizing sidebar scrolls Bookmarks/History to top → Resizing sidebar scrolls Bookmarks/History to selected bookmark
Product: Browser → Seamonkey

Comment 12

13 years ago
This is actually a wider problem with a <xul:tree> element used to display
bookmarks and history. I'll attach a testcase in a moment.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050319
Firefox/1.0+

->Trees
Assignee: samir_bugzilla → jan
Component: Sidebar → XP Toolkit/Widgets: Trees
Keywords: testcase
Product: Mozilla Application Suite → Core
QA Contact: sujay
Summary: Resizing sidebar scrolls Bookmarks/History to selected bookmark → Resizing a tree scrolls to selected item

Comment 13

13 years ago
Created attachment 178312 [details]
testcase

Comment 14

13 years ago
*** Bug 278099 has been marked as a duplicate of this bug. ***

Comment 15

13 years ago
Still broken for Firefox 1.5 RC3 on Windows XP.  Reproducable - always.  When the sidebar scroll resets, it only resets to the top as previously reported if nothing has focus in the sidebar.  However, if a bookmark link was already clicked, then the scoll finds the last link that had focus in the sidebar.  Any resize action will mess up the scroll - the maximize button as well as border grippies.  Highly annoying for anyone who leaves the bookmarks sidebar open and needs to widen it to see long text.

Updated

11 years ago
Blocks: 257704

Updated

11 years ago
Blocks: 303943
Duplicate of this bug: 303943

Updated

11 years ago
Blocks: 163404
No longer blocks: 303943

Updated

11 years ago
Duplicate of this bug: 376187
Summary: Resizing a tree scrolls to selected item → Resizing a tree (e.g. sidebar) scrolls to selected item

Updated

11 years ago
Duplicate of this bug: 343980
Just making note that I am also seeing this scrolling behavior in Linux, so this is not a  Windows-only bug.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1a1pre) Gecko/2008070202 Minefield/3.1a1pre Firefox/3.0 ID:2008070202

Updated

10 years ago
Assignee: Jan.Varga → nobody
OS: Windows XP → All
QA Contact: xptoolkit.trees
Hardware: PC → All
Summary: Resizing a tree (e.g. sidebar) scrolls to selected item → Resizing a xul:tree (e.g. sidebar) scrolls to selected item

Updated

10 years ago
Duplicate of this bug: 442991

Updated

10 years ago
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: xptoolkit.trees → xptoolkit.widgets

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 454632
You need to log in before you can comment on or make changes to this bug.