Change of default SMTP server does not come into effect instantly

RESOLVED DUPLICATE of bug 222388

Status

MailNews Core
Networking: SMTP
--
major
RESOLVED DUPLICATE of bug 222388
16 years ago
9 years ago

People

(Reporter: Paul Mayer, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826

Looking at 96207 and 167834 and now this problem, it looks like the architecture
of the advanced SMTP settings (i.e., handling of the interface for multiple SMTP
servers) is not there yet.

This problem occurs when you delete the previous default server, and then set a
new server to be the default.  The default setting, (as set to "use default
server" in the advanced setup for each multiple account) is not accessed and a
send error is generated stating that server %s is not available etc.

Reproducible: Always

Steps to Reproduce:
1. Create a few SMTP server records in the advanced interface (fool around with
ok buttons that don't work while you're at it.)
2. Set one of them to the default. 
3. Go into your multiple accounts, and set some of them to use the default
4. Delete the default and set another one as default
5. Your there where you can't sent mail from those accounts which use the default.
Actual Results:  
Bad news!  Mozilla mail is useless, 'cause you can't send any mail!  (You have
to go to each account and specify a server, which defeats the idea of having a
default in the first place.)

Expected Results:  
set the default SMTP server, as requested, and have that value be made available
to all accounts that are set to use the default.

(None)
Worksforme on 2003101104-trunk/Win-Me if "Always Use Default Server" is
set(manually) at [Server Settings][Advanced] of all accounts.

(1) Change SMTP server setting of all accounts to "Always Use Default Server"
    -> value of "mail.identity.idN.smtpServer" becomes blank (about:config)  
(2) Try to delete current default SMTP server
    -> Unable to delete defaulted SMTP server
       because "delete" button is not available(grayed out) for defaulted server
(3) Add additional SMTP server (Dummy,SMTP server name=test.test.test)
(4) Try to send mail saved in drafts folder
    -> Error message for server_name=test.test.test was issued
(5) Change other(valid) SMTP server to defalut SMTP server
(6) Delete old default SMTP server(test.test.test)
(7) Try to send mail
    -> Mail was sent via. new default SMTP server successfully

I think real problem is:
  SMTP server is set to specific SMTP server
  (first defined SMTP server which is set as default SMTP server)
  instead of "Always Use Default SMTP server" on account definition?
Reporter, isn't it right?

Another case is possible.
Since old Mozilla had bugs in SMTP server definition,
 (1) multiple SMTP server entries were defined for a SMTP server
     when same SMTP server is specified on definition of additional accounts
 (2) different SMTP server entry(but same sever) is set
     as SMTP server to each account's SMTP server definition
Both bugs are already resolved but account definition done by old Mozilla can
not be corrected automatically.
If your accounts were defined by old Mozilla and above 2 problems exists,
you'd better to clean up of garbage.
  (1) Delete multiple SMTP server entries for same SMTP server
  (2) Set "Always Use Default SMTP Server" or specific SMTP server entry
      at [Server settings][Advanced] for all accounts   
Reporter, Still problem? See Bug 220761 and Bug 202308 .

Note: Bug 220761 was already closed as "INVALID" by bug opener.
> With multiple SMTP servers specified 'DEFAULT' is ignored

Comment 4

14 years ago
In the "Advanced Outgoing Sever (SMTP) Settings" dialogue box, NO matter which
SMTP server is set default, always the first/top SMTP server in the list is used.

Comment 5

14 years ago
Mail/News has a poorly designed SMTP user interface. This type of problem is
normally an enhancement, and would thus be of low priority to developers.

However, the bad design of the SMTP user interface is causing a number of users
to file spurious bugs. It is also resulting in a lot of grief (the magnitude of
which is not recognized, because it is dispersed between a number of different
bugs).

This is a problem with both Mozilla Mail/News and Thunderbird.

It remains a problem even in these, more recent versions:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113
Mozilla Thunderbird 0.5 (20040207)

Although no single SMTP bug has that many votes, the sum of votes for those bugs
partially or wholly dependent upon UI problems is rather large.

These bugs aren't really bugs, but are users who are mislead by the UI:
bug 228643
  - Outgoing Server settings ignore the default
bug 170089
- default server value not being used to send mail.  Mail cannot be sent.
bug 222064
- don't remember the updated default SMTP server. Can't use more then one SMTP
server

These bugs all mention or are in part due to bad UI design:
bug 202468
  - 3 votes - Simpler, more consolidated UI for SMTP server settings
bug 52384
  - 27 votes - difficult to define multiple smtp servers and
quickly/automatically switch between them
bug 154453
  - 2 votes - SMTP setting dialog totally corrupted
bug 218518 comment 4 and comment 5
 - unable to select alternate SMTP server in Account Settings
bug 226017
- Should try other SMTP servers when default doesn't work

Note that all of these bugs can't simply be marked closed and consolidated into
one bug (most contain more than one issue with the way SMTP servers are entered
& organized).

However, I suggest that the UI aspects of these bugs be consolidated into bug
202468 . 

Let's all vote for it, and hopefully get some work done on this UI!
Andy

Comment 6

14 years ago
*** Bug 223031 has been marked as a duplicate of this bug. ***

Comment 7

14 years ago
*** Bug 222064 has been marked as a duplicate of this bug. ***

Comment 8

14 years ago
*** Bug 228643 has been marked as a duplicate of this bug. ***

Comment 9

14 years ago
It seems that chaninging of the default SMTP server often requires Mozilla
restart to come into effect.

Hardware/OS -> All/All
Clarifying summary
Confirming
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
Summary: default server value not being used to send mail. Mail cannot be sent. → Change of default SMTP server does not come into effect instantly

Comment 10

14 years ago
*** Bug 202308 has been marked as a duplicate of this bug. ***
One and a half year since this bug has been reported but doesn't seem to be
changed.  Is it because the component isn't correct?  Maybe it needs to be "Mail
backend"?

Comment 12

14 years ago
*** Bug 247372 has been marked as a duplicate of this bug. ***

Comment 13

14 years ago
*** Bug 247801 has been marked as a duplicate of this bug. ***

Comment 14

14 years ago
thats right, if i change the default smtp server, nothing happens, and the old
one is still used...

i edited the prefs.js on line 54: 
ser_pref("mail.identity.id1.smtpServer", "smtp2");

then it works! (but thats not the good way ;)

greetings
I think default SMTP server change related bugs can be closed as any of next three:
 - "INVALID" if reporter believes his fault.
 - "DUP of Bug 202468" if reporter feels current SMTP server related UI
   is very confusing.
 - "DUP of Bug 222388" if reporter thinks Mozilla's fault,
   "Always use default SMTP server" should be set on account definition
   instead of specific SMTP server which is set as default SMTP server
   when account is defined.
Oh!  Do you mean with Mozilla still running you changed the prefs.js file and it
worked?  Oh, I always thought prefs.js content is read at the very beginning of
Mozilla and successive access to this file is writing.  So visibly it's not.

Comment 17

13 years ago
Reporter has not said anything since opening the bug, despite multiple requests 
for responses.  Duping to a bug where there has been some patch activity.

*** This bug has been marked as a duplicate of 222388 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 18

13 years ago
Bug 222388 is different from this one.
This bug is about change of the Default SMTP server and how it affects existing
accounts, see comment 9. Nothing to do with newly created accounts which bug
222388 is about.
 
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Product: MailNews → Core
(In reply to comment #18)
Max Alekseyev, following is your request?
 - Change account's SMTP choice automaticaly
   when default SMTP server is changed,
   if a account's choice is the specific SMTP server
      which is previous default SMTP server.

If yes, it shouldn't.
Changing of default SMTP server should not affect account's SMTP choice, because
SMTP definition(including default or not) and account's SMTP choice is independent.
"Which is default" and "Whether use default or not" is completely defferent thing.
If a account's choice is a specific SMTP server, it cannot/shouldn't mean
"Always use default SMTP server" even when the SMTP server is set as default
SMTP server.
If defaulted SMTP server has to be used any time even after default SMTP server
is changed, a account's choice has to be "Always use default SMTP server".

User's usual expectation when accout definition is "Always use default SMTP
server" as you, including me.
However, Mozilla's current setting on account definition is "a specific SMTP
server" which is defaulted when account definiton.
This is the main cause of many user's confusion and this is the reason why Bug
222388 was opened and is kept open and is in development.

Real problem I know on default SMTP server change even when "Always use default
SMTP server" is next problem only.
 - Previously defaulted SMTP server is used on send
   even though user sets "Always use default SMTP server" for the account,
   if default SMTP server is changed while mail editing.
This is because the specific(defaulted) SMTP server is already selected
when start of mail editing(=choice of identity=choice of from address).
This can probably be avoided by temporary change of identity(From:).
Newly defaulted SMTP server will be get when original identity is choosed again.
 

Comment 21

13 years ago
(In reply to comment #19)
> (In reply to comment #18)
> Max Alekseyev, following is your request?
>  - Change account's SMTP choice automaticaly
>    when default SMTP server is changed,
>    if a account's choice is the specific SMTP server
>       which is previous default SMTP server.

Nope.

[...]

> Real problem I know on default SMTP server change even when "Always use default
> SMTP server" is next problem only.
>  - Previously defaulted SMTP server is used on send
>    even though user sets "Always use default SMTP server" for the account,
>    if default SMTP server is changed while mail editing.

Previously, change of default SMTP server was taken into effect only after
Mozilla restart. And this is what this bug is about. But as I see now the
problem seems to be fixed.

Marking as FIXED

Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED

Updated

13 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 22

13 years ago
Max Alexseyev, it's considered customary to ask the reporter if the bug is in 
fact working as expected before marking it.  Also, unless you can point to a 
specific patch that fixed the problem, the preferred resolution is WorksForMe.

Paul Mayer, is this bug still a problem for you with current builds of either 
Mozilla or Thunderbird?

Comment 23

13 years ago
*** Bug 276013 has been marked as a duplicate of this bug. ***
According to comment #21, Max Alekseyev(re-opener)'s problem is found that
different problem form this bug, and is found that his problem is already
WORKSFORME.
Closing as DUP of bug 222388 again as comment #17 did, because no response from
bug opener since bug open.

*** This bug has been marked as a duplicate of 222388 ***
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.