Closed Bug 1700917 Opened 1 year ago Closed 1 year ago

Perma Android xpcshell unexpected passes when Gecko 89 merges to Beta on 2021-04-19

Categories

(GeckoView :: General, defect, P1)

Unspecified
Android

Tracking

(firefox-esr78 unaffected, firefox86 unaffected, firefox87 unaffected, firefox88 unaffected, firefox89+ verified)

VERIFIED FIXED
89 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox86 --- unaffected
firefox87 --- unaffected
firefox88 --- unaffected
firefox89 + verified

People

(Reporter: aryx, Assigned: agi)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [geckoview:m89])

Attachments

(2 files, 1 obsolete file)

[Tracking Requested - why for this release]:

Each test chunk contains different tests and unexpected passes. Chunks with the same number contain the same unexpected passes.

Flags: needinfo?(agi)

I know what the problem is, patch incoming.

Assignee: nobody → agi
Severity: -- → S3
Flags: needinfo?(agi)
Priority: -- → P1
Whiteboard: [geckoview:m89]

Looks like spoofing the event is not enough as GeckoView intialization code
(indirectly) uses the profile folder.

We also catch exceptions coming from the init code and throw them appropriately
so we don't ignore errors during initialization.

Attachment #9211613 - Attachment is obsolete: true
Pushed by asferro@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2d138509c05b
Actually initialize the profile in GeckoView xpcshell. r=jmaher
https://hg.mozilla.org/integration/autoland/rev/6a72bfcd25fb
Force multi_e10s on xpcshell tests. r=aklotz
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch

Verified fixed in today's central-as-early-beta simulation.

Status: RESOLVED → VERIFIED
Has Regression Range: --- → yes
Keywords: regression
You need to log in before you can comment on or make changes to this bug.