Closed Bug 1700989 Opened 8 months ago Closed 8 months ago

The favicon is blank for a couple seconds if the audio stops playing while the mouse is in the tab bar

Categories

(Firefox :: Theme, defect, P3)

defect
Points:
1

Tracking

()

VERIFIED FIXED
89 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox87 --- unaffected
firefox88 --- disabled
firefox89 --- verified
firefox90 --- verified

People

(Reporter: jaws, Assigned: jaws)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [proton-tabs-bar])

Attachments

(1 file)

STR:
Go to YouTube and play a video
Pause the video
Move the mouse to the tab bar quickly

ER:
The audio indicator should be replaced by the favicon

AR:
There is a gap of a few seconds where no icon is visible

The mouse hover resets the starting value of the transition, effectively canceling the transition and moving immediately to the end state.

Assignee: nobody → jaws
Status: NEW → ASSIGNED
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/26cfe11b1a2f
Remove the fadeout on the tab-icon-overlay since transitioning the opacity won't work when the opacity property is changed due to mouse hover. r=desktop-theme-reviewers,harry
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch
Flags: qe-verify+

Verified as fixed on Windows 10 x64, macOS 10.15, Ubuntu 20.04 and on Windows 7 x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.