Closed Bug 1701151 Opened 7 months ago Closed 7 months ago

Crash in [@ mozilla::net::OpaqueResponseBlockingInfo::Report]

Categories

(Core :: Networking, defect)

Firefox 89
Desktop
All
defect

Tracking

()

RESOLVED FIXED
89 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox87 --- unaffected
firefox88 --- unaffected
firefox89 blocking fixed

People

(Reporter: pascalc, Assigned: edenchuang)

References

(Regression)

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 obsolete file)

Maybe Fission related. (DOMFissionEnabled=1)

Crash report: https://crash-stats.mozilla.org/report/index/b8c762c7-c838-4cc8-a8f3-dfc320210326

Reason: EXCEPTION_ACCESS_VIOLATION_READ

Top 10 frames of crashing thread:

0 xul.dll mozilla::net::OpaqueResponseBlockingInfo::Report netwerk/protocol/http/OpaqueResponseUtils.cpp:208
1 xul.dll mozilla::net::HttpBaseChannel::ReportORBTelemetry netwerk/protocol/http/HttpBaseChannel.cpp:5216
2 xul.dll mozilla::net::nsHttpChannel::DisableIsOpaqueResponseAllowedAfterSniffCheck netwerk/protocol/http/nsHttpChannel.cpp:10036
3 xul.dll imgLoader::GetMIMETypeFromContent image/imgLoader.cpp:2722
4 xul.dll NS_SniffContent netwerk/base/nsNetUtil.cpp:2814
5 xul.dll nsUnknownDecoder::DetermineContentType netwerk/streamconv/converters/nsUnknownDecoder.cpp:485
6 xul.dll nsUnknownDecoder::OnDataAvailable netwerk/streamconv/converters/nsUnknownDecoder.cpp:201
7 xul.dll mozilla::net::nsStreamListenerTee::OnDataAvailable netwerk/base/nsStreamListenerTee.cpp:86
8 xul.dll mozilla::net::nsHttpChannel::OnDataAvailable netwerk/protocol/http/nsHttpChannel.cpp:8317
9 xul.dll nsInputStreamPump::OnInputStreamReady netwerk/base/nsInputStreamPump.cpp:393

New Nightly significant crasher on build 20210325161138

Changelog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e8e9c8e8eaf13e98764887e23b2e4490b6a4c6cb&tochange=2da6d806f45732e169fd8e7ea9a9761fa7fed93d

Eden, could that be caused by the landing of bug 1696111 or bug 1695987?

Flags: needinfo?(echuang)

Nightly updates halted.

Yes, it is caused by the landing of bug 1696111, bug 1695987, and bug 1683131.

Flags: needinfo?(echuang)

Fixed by backout of the changes in comment 3. The next Nightlies should be unaffected.

Status: NEW → RESOLVED
Closed: 7 months ago
Keywords: regression
Regressed by: 1696111
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch
Assignee: nobody → echuang
Attachment #9213728 - Attachment description: WIP: Bug 1701151 - Opaque response blocking after UnknownDecoder recognizes the allowed or blocked type. → Bug 1701151 - Opaque response blocking after UnknownDecoder recognizes the allowed or blocked type. r=necko-reviewers

Comment on attachment 9213728 [details]
Bug 1701151 - Opaque response blocking after UnknownDecoder recognizes the allowed or blocked type. r=necko-reviewers

Revision D110901 was moved to bug 1701868. Setting attachment 9213728 [details] to obsolete.

Attachment #9213728 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.