Mail filters locked and poor performance-Mozilla crashed!

RESOLVED INVALID

Status

SeaMonkey
General
RESOLVED INVALID
16 years ago
14 years ago

People

(Reporter: Eduardo Bonsi, Assigned: asa)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
1-main email account unable to retrive emails from "netscape.net"
2-email filters very poor, can't stop the load of spam.

3-resulted of the crash, Hope that is not too much!

Date/Time:  2002-09-21 20:29:39 -0700
OS Version: 10.1.5 (Build 5S66)

Command:    Mozilla
PID:        435

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000134

Thread 0:
 #0   0x00000134 in 0x134
 #1   0x020811f0 in GetActiveWindow__15nsWindowWatcherFPP12nsIDOMWindow
 #2   0x0208b1c0 in DoDialog__15nsPromptServiceFP12nsIDOMWindowP19nsIDialogParamBl
 #3   0x0208aa5c in PromptPassword__15nsPromptServiceFP12nsIDOMWindowPCwPCwPPwPCwP
 #4   0x0208c264 in PromptPassword__8nsPromptFPCwPCwPPwPCwPiPi
 #5   0x052d353c in PK11PasswordPrompt__FP15PK11SlotInfoStriPv
 #6   0x0542c0e8 in pk11_GetPassword
 #7   0x0542c260 in PK11_DoPassword
 #8   0x0542ba1c in PK11_Authenticate
 #9   0x052e70b4 in Decrypt__19nsSecretDecoderRingFPUciPPUcPi
 #10  0x052e730c in DecryptString__19nsSecretDecoderRingFPCcPPc
 #11  0x055efddc in DecryptString__FPCcRPc
 #12  0x055f00f4 in wallet_Decrypt__FRC9nsCStringR9nsCString
 #13  0x055f0384 in Wallet_Decrypt
 #14  0x055f04a0 in Wallet_Decrypt2
 #15  0x055fe940 in si_Decrypt__FRC8nsStringR8nsString
 #16  0x05603720 in si_RestoreOldSignonDataFromBrowser__FP9nsIPromptPCciR8nsString
 #17  0x05603e80 in SINGSIGN_PromptPassword
 #18  0x055ee7ec in PromptPassword__20nsSingleSignOnPromptFPCwPCwPCwUiPPwPi
 #19  0x04e8cdcc in GetPasswordWithUI__19nsMsgIncomingServerFPCwPCwP12nsIMsgWindow
 #20  0x04e684c8 in GetPassword__14nsPop3ProtocolFPPcPi
 #21  0x04e6a7b4 in SendPassword__14nsPop3ProtocolFv
 #22  0x04e6e60c in 0x4e6e60c
 #23  0x04e9c038 in OnDataAvailable__13nsMsgProtocolFP10nsIRequestP11nsISupportsP1
 #24  0x01f860e0 in HandleEvent__22nsOnDataAvailableEventFv
 #25  0x01f95110 in HandlePLEvent__23nsARequestObserverEventFP7PLEvent
 #26  0x005ef4e0 in PL_HandleEvent
 #27  0x005ef34c in PL_ProcessPendingEvents
 #28  0x0059735c in ProcessPendingEvents__16nsEventQueueImplFv
 #29  0x021e7d8c in ProcessPLEventQueue__26nsMacNSPREventQueueHandlerFv
 #30  0x021e7c30 in RepeatAction__26nsMacNSPREventQueueHandlerFRC11EventRecord
 #31  0x00c27b14 in DoRepeaters__8RepeaterFRC11EventRecord
 #32  0x021fe2c8 in DispatchEvent__16nsMacMessagePumpFiP11EventRecord
 #33  0x021fe000 in DoMessagePump__16nsMacMessagePumpFv
 #34  0x021fd97c in Run__10nsAppShellFv
 #35  0x021ba44c in Run__17nsAppShellServiceFv
 #36  0x004c9e24 in main1__FiPPcP11nsISupports
 #37  0x004ca7dc in main

Thread 1:
 #0   0x7000496c in syscall
 #1   0x70557600 in BSD_waitevent
 #2   0x70554b80 in CarbonSelectThreadFunc
 #3   0x7002053c in _pthread_body

Thread 2:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x705593ec in CarbonOperationThreadFunc
 #3   0x7002053c in _pthread_body

Thread 3:
 #0   0x70044cf8 in semaphore_timedwait_signal_trap
 #1   0x70044cd8 in semaphore_timedwait_signal
 #2   0x7003f2b8 in _pthread_cond_wait
 #3   0x70283e9c in TSWaitOnConditionTimedRelative
 #4   0x7027d740 in TSWaitOnSemaphoreCommon
 #5   0x702c2078 in TimerThread
 #6   0x7002053c in _pthread_body

Thread 4:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x70250aa8 in TSWaitOnCondition
 #3   0x7027d728 in TSWaitOnSemaphoreCommon
 #4   0x70243d0c in AsyncFileThread
 #5   0x7002053c in _pthread_body

Thread 5:
 #0   0x7003f4c8 in semaphore_wait_signal_trap
 #1   0x7003f2c8 in _pthread_cond_wait
 #2   0x7055b884 in CarbonInetOperThreadFunc
 #3   0x7002053c in _pthread_body

Thread 6:
 #0   0x70000968 in mach_msg_overwrite_trap
 #1   0x700059f4 in mach_msg
 #2   0x70026a1c in _pthread_become_available
 #3   0x70026714 in pthread_exit
 #4   0x70020540 in _pthread_body


PPC Thread State:
  srr0: 0x00000134 srr1: 0x4000f030                vrsave: 0x00000000
   xer: 0x00000018   lr: 0x020811f0  ctr: 0x00000134   mq: 0x00000000
    r0: 0x00000134   r1: 0xbfffe190   r2: 0x051e2001   r3: 0x051e63c4
    r4: 0xbfffe210   r5: 0x055a3100   r6: 0x020ae520   r7: 0xffffffff
    r8: 0x00112490   r9: 0x80240e10  r10: 0x00000024  r11: 0x80003710
   r12: 0x051e3198  r13: 0x00000000  r14: 0x00000036  r15: 0x0005f980
   r16: 0x00000001  r17: 0x80160fa8  r18: 0x00060858  r19: 0x00001807
   r20: 0x00000000  r21: 0x0000001c  r22: 0x70004224  r23: 0x700042b8
   r24: 0x7016b0c8  r25: 0x006bac3c  r26: 0x8081ab5c  r27: 0xc0d89c00
   r28: 0x00000000  r29: 0xbfffef00  r30: 0x2a150000  r31: 0x00000001

**********

Comment 1

16 years ago
Eduardo, please file one bug for each one of the problems you mention, and
please use the Bugzilla Helper at
[http://bugzilla.mozilla.org/enter_bug.cgi?format=guided]. It will help ensure
you provide all the necessary information. Be sure to search the bug database
before filing to make sure the issue isn't already reported.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 2

16 years ago
Eduardo, also, when you file bug #3 about the crash, be sure to *attach* the
crash report to the bug as a text file, and don't paste it into the comment box.
Thanks.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.