Closed Bug 1701474 Opened 8 months ago Closed 8 months ago

Selecting a bookmark and a folder no longer gives option to delete in the context menu

Categories

(Firefox :: Bookmarks & History, defect, P2)

Firefox 88
defect

Tracking

()

VERIFIED FIXED
89 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox86 --- unaffected
firefox87 --- unaffected
firefox88 --- verified
firefox89 --- verified

People

(Reporter: ke5trel, Assigned: mak)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression, Whiteboard: [proton-context-menus] [priority:2a])

Attachments

(1 file)

STR:

  1. Make a selection of multiple bookmark items in the sidebar or library, including at least one bookmark and one folder.
  2. Right-click the selection and note the context menu items.

When only bookmarks are selected: "Remove bookmarks"
When only folders are selected: "Delete"
When both bookmarks and folders are selected: No delete/remove option.

The naming is also inconsistent between bookmarks and folders, so it is unclear if "Delete" or "Remove" should be expected when both are selected (history uses "Delete pages").

The Delete key can still be used normally as a workaround.

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=564a8ee8f4d479cf4b8c3d51479c0bc45123f517&tochange=9a043bb287a544d48bfe87fbe8adad72390009b4

Regressed by Bug 1692668.

this is another "selection" bug, it used to apply to anything, now it applies to either bookmarks or containers, but when there is a multi selection it doesn't have a "selection" attribute since it can be mixed. I'm not sure there is a valid combination to do what Bug 1692668 was trying to do, this would probably require to duplicate the delete entry and have one for single and one for multi selection.

Whiteboard: [proton-context-menus]
Assignee: nobody → mak
Status: NEW → ASSIGNED
Priority: -- → P2

The backout in bug 1700929 should fix this for 88 while we investigate the "right" fix.

Whiteboard: [proton-context-menus] → [proton-context-menus] [priority:2a]

Fixed by bug 1700929.

Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch

Verified that this is fixed in latest Nightly 89.0a1 using the patch from bug 1700929 comment 23. Also verified in Firefox 88.0b7 after backing out bug 1700929 across platforms (Windows 10, macOS 10.14 and Ubuntu 18.04).

Status: RESOLVED → VERIFIED
Depends on: 1700929
You need to log in before you can comment on or make changes to this bug.