Closed Bug 170155 Opened 20 years ago Closed 17 years ago

[l10n] back keyboard shortcut does not work with Danish keyboard

Categories

(Camino Graveyard :: General, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID
Camino1.0

People

(Reporter: jonas, Assigned: mikepinkerton)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20020909
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20020909

On a Danish keyboard "[" is reached using option-8. The keyboard shortcut for
"back" should therefore be command-option-8, however, this does not work
(Chimera does not show any reaction at all). The keyboard shortcuts for forward
(command-option-9), next tab (command-option-shift-9), and previous tab
(command-option-shift-8) all work.

Reproducible: Always

Steps to Reproduce:
1. Go to a webpage
2. Go to a different webpage
3. press command-option-8 (on a Danish keyboard), nothing happens. (Go back
manually using the menu or toolbar, then press command-option-9 and you are
moved forward.)

Actual Results:  
Nothing (see above).

Expected Results:  
Gone to the previous page.
Jonas, FYI, it appears recent builds have restored command+leftArrow as an
alternative Back shortcut when it's not needed by a text field. So, that could
be a workaround for you.
Confirmed.
Status: UNCONFIRMED → NEW
Ever confirmed: true
You can also use the Delete key to go back. Is that enough options?
What does IE do for Back, on your keyboard, incidentally?
still an issue?
Assignee: saari → pinkerton
Target Milestone: --- → Camino1.0
Still doesn't work (at least with a Norwegian keyboard which also have option-8
for [ ). However, I belive Apple is to blame since this doesn't work in the
Finder either :-( Cmd-Opt-9 for forward works fine both in Camino and Finder.
Mabye because command-option-8 turns accessibility zoom on and off
Turning of "accessibility zoom on and off" in the system preferences enables the
back keyboard shortcut in Camino (and Finder). I don't think Camino as default
should override system keyboard shortcuts, so I guess theres not much that can
be done to fix this :-( Since Camino already has two other shortcuts for back
(backspace and Cmd-right arrow) I suggest WONTFIX.
Simon, Mike, since allowing this would change the default Mac OS X behaviour, I
definitely suggest WONTFIX.
What does Safari use for Back? Is it localized to something else?
Safari uses Cmd-[ for back on English localization, but Cmd-leftarrow on
Norwegian localization (stupidly this follows the system language and not the
keyboard layout, running an English system with a another keyboard is quite
common). Camino already supports both of these on both localizations, however,
localizers may want to change which one is shown in the menu?
Adding [l10n] as it's potential at the moment and CCing Ludo to take a look.
Summary: back keyboard shortcut does not work with Danish keyboard → [l10n] back keyboard shortcut does not work with Danish keyboard
Just for the record, Safari also supports all three versions of back (Cmd-[,
Cmd-leftarrow, and Delete) in both localizations, the only difference AFAICT is
what is shown as shortcut in the menu.
I'll ask the danish localizer on what he thinks is the right way to go.
Note that command-arrow combinations should be reserved for selection (move to
start/end of line) so we don't want to use those.
In the Danish localization of Safari the following options are avilible for
forward/back:

command-shift-9("command-)")/command-shift-8("command-(")

command-right arrow/command-left arrow

backspace for back.

I think Camino-da should follow Safari with:

command-shift-9("command-)")/command-shift-8("command-(")

and when no text fields are in use:

command-right arrow/command-left arrow

backspace for back.

The menu shortcut in the danish l10n should be like this: "command( eller(or)
CommandLeftArrow" because it would be clear what happend when a text field was
active and it would do no harm to the text. The CommandLeftArrow is much easier
to use so people should be told that it exist.

If it is possible it would be best if Camino followed the keybord layout. on
those two strings.
Bump.

How hard is this? Just a matter of changing some shortcuts?
No longer blocks: 301740
bugs in localizations don't belong here. if there is code that needs to change
in order to support this (i'm not sure there is) then reopen this bug.
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.