Closed Bug 1701566 Opened 2 months ago Closed 1 month ago

DevTools Netmonitor - Analyze button icon no longer centered when Search/Blocking tab opened

Categories

(DevTools :: Netmonitor, defect, P3)

defect

Tracking

(firefox-esr78 wontfix, firefox86 wontfix, firefox87 wontfix, firefox88 wontfix, firefox89 verified, firefox90 verified)

VERIFIED FIXED
89 Branch
Tracking Status
firefox-esr78 --- wontfix
firefox86 --- wontfix
firefox87 --- wontfix
firefox88 --- wontfix
firefox89 --- verified
firefox90 --- verified

People

(Reporter: cfogel, Assigned: blueyoshi77)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: good-first-bug, regression)

Attachments

(2 files)

Attached image centeNmonitor.png

Affected versions

  • 88.0a1(2021-03-25); 88.0b2;

Affected platforms

  • Windows 10, Ubuntu 20;

Steps to reproduce

  1. Launch Firefox, enable DevTools;
  2. Open the Search/Blocking tab;
  3. Grab and resize either the Search/Blocking section or the browser window shrinking the width in the requests list section;

Expected result

  • buttons and elements reflow as expected, elements remain centered;

Actual result

  • button for Analyze shrinks in width, but the icon is not centered it remains offset to left;

Regression range

  • while checking for the regression window, issue was manifesting but only with 1-3 pixels making it not as visible; range if for when it became more obvious:
  • First bad: 2020-05-13;
  • Last good: 2020-05-12;
  • Pushlog: URL;
  • potential regressor: bug 1634380 seems the likely candidate based on the pushlog;

Additional notes

  • attached screenshot to best illustrate the issue.
Has Regression Range: --- → yes
Has STR: --- → yes
OS: Unspecified → All

Thanks for the report and regression window Cristian!
I can reproduce it on my machine: Win10 + Firefox Nightly

Honza

Blocks: 1701650
Priority: -- → P3

Hi - May I take this one? This will be my first contribution. I took a look at the code and I think it may be an issue with the CSS.

Sure! Assigned to you.
Feel free to ask any questions if you need help.

Assignee: nobody → blueyoshi77

Thanks! I have a fix working and am ready to commit it. Is it correct to set the reviewer=Honza in the commit message?

(In reply to Larissa from comment #5)

Thanks! I have a fix working and am ready to commit it. Is it correct to set the reviewer=Honza in the commit message?

Yes that's correct. You can also send review to me if you like i.e reviewer=bomsy

Pushed by jodvarko@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bbfd6d1b4f05
Removed flexbox from outer div (.notice-perf-mesage). r=bomsy,Honza
Status: NEW → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch

Does this need a Beta approval request?

Flags: needinfo?(hmanilla)

Hey Ryan,
No not critical. Thanks

Flags: needinfo?(hmanilla)
QA Whiteboard: [qa-89b-p2]

Hello,
I have reproduced the issue using STR from comment 0, on an affected Nightly build 2021-03-25.

The fix was verified using the latest Nightly (20210507095221) and Firefox 89.0b9 (2021-05-06), on both Ubuntu 20.04 and Windows 10x64.
The issue is not reproducing anymore.

Thanks!

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.