Javascripts can close the browser window without warning.

RESOLVED DUPLICATE of bug 32571

Status

RESOLVED DUPLICATE of bug 32571
16 years ago
14 years ago

People

(Reporter: hybrid, Assigned: asa)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.1) Gecko/20020826

The following simple javascript: <script>window.close()</script> closes the
Mozilla browser window without warning, which is annoying in forums with html
enabled and pesty kids.  Internet Explorer gives a warning about this, but in
Mozilla the page closes before you can see it.  In Advanced options about
Javascript, you can turn off scripts that resize the window, move it, or open a
new one, but there's no setting to turn off window.close().

Reproducible: Always

Steps to Reproduce:
1.Make a html page that contains <script>window.close()</script>
2.Open it in Mozilla

Actual Results:  
The browser window closed.

Expected Results:  
Ask me if I want to close the window or not, or have an option where you can
turn unwanted closing of browser windows off.

Comment 1

16 years ago
Duplicate of bug 32571 (via bug 151469)

*** This bug has been marked as a duplicate of 32571 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.