Closed Bug 1701682 Opened 8 months ago Closed 22 days ago

[Proton] [High Contrast] The "Remember this decision" checkbox and on button hover effects are not visible

Categories

(Firefox :: Site Permissions, defect, P2)

Desktop
macOS
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox87 --- disabled
firefox88 --- disabled
firefox89 --- affected

People

(Reporter: tbabos, Unassigned)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [proton-door-hangers][priority:2c])

Attachments

(1 file)

Attached video High Contrast bug.mov

Tested on:
Nightly 89.0a1

TestedPlatform:
MacOS 10.15

Have the following prefs enabled:
browser.proton.enabled
browser.proton.doorhangers.enabled
Light Theme
Increased Contrast from MacOS settings

Steps to reproduce:

  1. Open https://mozilla.github.io/webrtc-landing/gum_test.html
  2. Click on the Camera or Microphone button
  3. Check the Permission Panel
  4. Hover over the Allow/Block buttons

Expected Results:
The checkbox should be visible with High Contrast mode
The hover effect should be visible one the Allow/Block buttons

Actual Results:
The "Remember this decision" checkbox and on button hover effects are not visible

Notes:
On Dark theme only the missing hover effect is reproducible. The checkbox is visible.
Not reproducible on the old permission panel UX.

Priority: -- → P2
Whiteboard: [proton-door-hangers] → [proton-door-hangers][priority:2c]

Hey Mike, do we have any plans to fix this and uplift to Beta?

Flags: needinfo?(mconley)

Hi tbabos,

No, I don't think so - this is priority:2c, and is unlikely to get fixed in time for a beta uplift.

Flags: needinfo?(mconley)

Updating the current status on Beta 89:

  1. The checkbox now appears with High Contrast as well.
  2. Hover effect and the buttons for Allow/Block are missing (only button string is displayed).

I just figured out video recording on macOS with High Contrast is not relevant since it just increases the screen contrast, thus not visible on recordings.

Blocks: 1729031

Which contrast setting are you using to replicate this bug? I have normal display high contrast mode enabled on my MacBook and the button backgrounds are currently visible for me. Are you still able to replicate the bug on your end?

Flags: needinfo?(timea.babos)

Hey Danielle,
This is an older issue and yes I can also confirm it is no longer reproducible on the latest Nightly 96.0a1. Closing it as resolved:worksforme, thanks for checking on this!

Status: NEW → RESOLVED
Closed: 22 days ago
Flags: needinfo?(timea.babos)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.