If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Event Dialog: on daylight saving time start day, hour between 02:00 and 02:59 decremented

NEW
Unassigned

Status

Calendar
Dialogs
--
minor
15 years ago
7 years ago

People

(Reporter: gekacheka, Unassigned)

Tracking

(Depends on: 1 bug)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2a) Gecko/20020910
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2a) Gecko/20020910, 2002091910-cal

In New/Event dialog, on the morning daylight saving time starts (6 April 2003 in
US):

Times between 02:00 and 02:59 inclusive are decremented, falling *back* one
hour.  They should be incremented, springing *forward* one hour, since clocks
are set forward at 02:00 standard time to 03:00 daylight time.  This happens
immediately upon choosing the time in the time picker/chooser.   



Reproducible: Always

Steps to Reproduce:
In a time zone which uses daylight saving time:
1. New Event
2. Choose date 2003 April 6 (daylight saving time start in US.)
3. Choose time (either start or end) between 02:00 and 02:59 am.  (daylight
saving time starts at 02:00 in US).

Actual Results:  
Time was decremented one hour, to between 01:00 and 01:59 am.

Expected Results:  
Time should be incremented one hour, to between 03:00 and 03:59 am.

This can erroneously cause duration to be negative (start at 01:30, end at
02:00, end gets reset to 01:00)..

Updated

15 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → 0.9

Comment 1

14 years ago
New contact from mikep@oeone.com to mostafah@oeone.com
Filter on string OttawaMBA to get rid of these messages. 
Sorry for the spam.
Assignee: mikep → mostafah
Status: ASSIGNED → NEW

Comment 2

13 years ago
Aditionally, in timezones where the switch to DST happens at midnight (ex.:
Australia/Melbourne), an all-day event that happens to fall on the day of the
switch is actually displayed on the previous day.

To reproduce: set your timezone to Australia/Melbourne. Go to Oct. 31st, 2003.
Set up an all day event, recurring anually. Look at the calendar for Oct. 2004:
the event will show up on the 30th.

Comment 3

13 years ago
gekacheka,
   This one also WFM on both Sunbird 0.2/2005011113-cal and on trunk.  Are you
still able to reproduce?
(Reporter)

Updated

13 years ago
Depends on: 294908
(Reporter)

Comment 4

13 years ago
This does not work for me in either case.

trunk build was Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2)
Gecko/20050505 Mozilla Sunbird/0.2+

The problem affects JavaScript Date.  Filed bug 294908, blocking this bug.

Updated

12 years ago
QA Contact: colint → sunbird

Comment 5

12 years ago
Per comment 2, Australia uses 2:00am not midnight.

I will retest this example, with latest Sunbird nightly.
Reassigning all automatically assigned bugs from Mostafa to nobody@m.o

Bugspam filter: TorontoMostafaMove
Assignee: mostafah → nobody

Comment 7

11 years ago
Further to comment 5

> To reproduce: .. set timezone to Australia/Melbourne
> .. Oct 31st, 2003 .. all day event, recurring anually
> .. for Oct. 2004 .. event will show up on the 30th.

Retested on latest Sunbird (20060713 Sunbird/0.3a2+), and event shows up (correctly) on 31st for 2004, 05, 06, etc.

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Comment 8

11 years ago
Retested of originally stated issus, on latest Sunbird (20060713 Sunbird/0.3a2+) using Wellington, New Zealand (daylight start 2:00am first Sunday) instead.  This should remove any other extraneous factors, as that is my home settings for: OS, SB, TZ, etc.

Using 'Steps to produce' verified that this remains UNRESOLVED

Wellington, NZ - Daylight Start (1st Sunday October)

Start or end time between 02:00 and 02:59 is decremented 1hr, NOT incremented.
 (Note: all times as auto-adjusted, with no attempt to override)

(a.) Add event  start 02:00, end 03:00; shows as  start 01:00, end 03:00
  SHOULD BE  start 03:00, end 04:00
(b.) Add event  start 01:30, end 02:30; shows as  start 01:30, end 01:30
  SHOULD BE  start 01:30, end 03:30

Wellington, NZ - Daylight End (3rd Sunday March)

Start or end time between 02:00 and 02:59 are UNCHANGED.
 (Note: all times as auto-adjusted, with no attempt to override)

(c.) Add event  start 01:00, end 02:00; shows as  start 02:00, end 02:00
  SHOULD BE  start 01:00DT, end 01:00ST!
  (NOTE: end date/time needs notation to denote within intercalary extra hour!?)
(d.) Add event  start 02:00, end 03:00; shows as  start 02:00, end 03:00
  NO METHOD to select  02:00DT/01:00ST  for start or end time
  ONLY SUPPORTS  start 02:00ST, end 03:00ST
  (NO SUPPORT for  start 01:00ST, end 02:00ST)

Comment 9

11 years ago
(In reply to comment #8)
> Using 'Steps to produce' verified that this remains UNRESOLVED
Sorry, I misunderstood your previous comment.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Status: REOPENED → NEW
Component: Sunbird Only → General
OS: Windows 2000 → All
QA Contact: sunbird → general
Hardware: PC → All
Target Milestone: 0.9 → ---
gekacheka and Andrew, could you pls check if this bug is still present in the latest trunk / 0.8pre branch builds?


(In reply to comment #4)
> The problem affects JavaScript Date.  Filed bug 294908, blocking this bug.

The bug that seems to block 294908 has been fixed for quite some time already.
(Reporter)

Comment 11

10 years ago
Javascript Date does not keep track of historical changes to daylight savings time, and US daylight saving time has been extended, so currently to reproduce this behavior in a US timezone use March 9 2003.

new Date(2003,02,09, 02,30,00)

produces

Sun Mar 09 2003 01:30:00 GMT-0500 (Eastern Standard Time)

Thinking about this again now,
  02:30 does not exist on the day that US daylight/summer time starts
    (spring forward from 01:59 to 03:00).
  Two alternatives are either to use 
     01:30 standard time or 03:30 daylight time.
  It is usually better to be early than late.  For alarms, the current behavior is better (e.g., alarm to get up and leave to catch an early morning flight).

Another alternative would be to try to detect when users enter a nonexistent time like this and warn them, but that would be rarely used.  Also it is not clear what to do for the corresponding time when daylight/summer time ends --- popup a dialog asking the user to pick between 02:30 daylight time and 02:30 standard time?  Such code might be more trouble to maintain than it is worth.

Do competitors (such as iCal, Outlook, Vista calendar, etc.) detect these special case times at daylight/summer time shifts and warn the user?
(Reporter)

Updated

10 years ago
Severity: normal → minor

Updated

9 years ago
Duplicate of this bug: 461666

Updated

9 years ago
Duplicate of this bug: 485738
Component: General → Dialogs
QA Contact: general → dialogs

Updated

7 years ago
Duplicate of this bug: 608602
You need to log in before you can comment on or make changes to this bug.