Event Dialog: year is not visible in start date field (field too narrow or date too wide)

RESOLVED FIXED

Status

Calendar
Sunbird Only
--
minor
RESOLVED FIXED
15 years ago
11 years ago

People

(Reporter: gekacheka, Assigned: Mostafa Hosseini)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2a) Gecko/20020910
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2a) Gecko/20020910, 2002091910-cal

With long month names like October, the start date field of the event dialog
cuts off the year so it is not visible.  

Suggest making this field wider.
(Alternative is to use shorter form of weekday and month)

Reproducible: Always

Steps to Reproduce:
1. In new event dialog, choose a date with long month name, such as october.


Actual Results:  
The year is not visible within the start date field.

Expected Results:  
The year should be visible within the start date field.

Workaround:  to check the year, click on the date and the date picker will pop
up showing the date.  Click outside the date picker to get rid of it.

Updated

15 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Reporter)

Comment 1

15 years ago
Related bug:  169107

The max width for fields with class="date-text-class" appears to be defined to
be 10em in 
Mozilla/chrome/calendar/skin/modern/calendarEventDialog.css

Suggest maybe moving the picker icons to the left side so the width of the field
doesn't have to have a maximum.

In English, the widest date format is probably something like
   Wednesday, September 25, 2002
(29 fixed width chars); I don't know if there are wider formats in other
languages, so it would be safest to make it the maximum width possible.
(Reporter)

Comment 2

15 years ago
Also in Mozilla/chrome/calendar/skin/classic/calendarEventDialog.css

Comment 3

14 years ago
New contact from mikep@oeone.com to mostafah@oeone.com
Filter on string OttawaMBA to get rid of these messages. 
Sorry for the spam.
Assignee: mikep → mostafah
Status: ASSIGNED → NEW

Comment 4

14 years ago
I'm not seeing this, it seems short date is used now instead...

gekacheka, could you please confirm if you still see this or not.
(Reporter)

Comment 5

14 years ago
Thanks, it looks like this was fixed by mikep 2002-10-25 which created the
separate datepicker and displayed an explicitly constructed short date.  It is
definately fixed by the patch for bug 185394 which formats the localized short date.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
The bugspam monkeys have been set free and are feeding on Calendar :: Sunbird Only. Be afraid for your sanity!
QA Contact: colint → sunbird
You need to log in before you can comment on or make changes to this bug.