gettyimages.com - dynamic menus misplaced

RESOLVED DUPLICATE of bug 212874

Status

Tech Evangelism Graveyard
English US
RESOLVED DUPLICATE of bug 212874
16 years ago
3 years ago

People

(Reporter: gustavo, Unassigned)

Tracking

Details

(Whiteboard: [technote needed] [how not to example], URL)

Attachments

(5 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020623 Debian/1.0.0-0.woody.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020623 Debian/1.0.0-0.woody.1

the dynamic menus are misplaced , so the page is unusable

Reproducible: Always

Steps to Reproduce:
1.go to the url
2.put the mouse pointer over the menus on the bottom
3.confirm that the menus pop up in the middle of the webpage instead of its
proper place

Actual Results:  
the menus pooped up out of place

Expected Results:  
put the menus in place

I don't know if this is a mozilla problem or their source code bug

Comment 1

16 years ago
After looking at the same page in IE, and comparing w/ Mozilla, something is
definitely wrong here. I'll post pictures in a second.
However, I think there is deifnitely somehting wrong with the page, because it
seems that the menus in Mozilla are no all piling up in some default spot, but
are placed in vertical sequence, as if they are all present, but only one is
visible at a time.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
Created attachment 100158 [details]
Mozilla, no mouse over

Comment 3

16 years ago
Created attachment 100159 [details]
Mozilla, mouse over 'images'

Comment 4

16 years ago
Created attachment 100160 [details]
Mozilla, mouse over 'motion'

Comment 5

16 years ago
Created attachment 100161 [details]
IE, no mouse over

Comment 6

16 years ago
Created attachment 100162 [details]
IE, mouse over 'images'

Comment 7

16 years ago
The intention seems to be that these "menus" should be positioned because the
both 'top' and 'left' are specified. The problem is that 'position' lacks
a value. The "menu" DIVs have CSS class of "dropDownContainer", yet there are
no rules that I could find for this class.

I added the following CSS rules to the page and then it works better:
#topNav { position:relative;}
.dropDownContainer{position:absolute;}

The remaining problem is that everything is wrapped in a <DIV align=center>
which makes the parent of the menus have offset 0 but still its content
is centered. You can around this by changing:

<div id="globalNav" name="globalNav">

to 

<table><tr><td>
<div id="globalNav" name="globalNav">


or something along those lines...

--> Tech Evangelism
Assignee: jst → susiew
Severity: major → normal
Component: DOM HTML → US General
OS: Linux → All
Product: Browser → Tech Evangelism
QA Contact: stummala → zach
Hardware: PC → All
Version: other → unspecified

Comment 8

16 years ago
See also another Evang bug for this site, bug 172550

Comment 9

16 years ago
*** Bug 172550 has been marked as a duplicate of this bug. ***
*** Bug 174415 has been marked as a duplicate of this bug. ***
I'm also seeing this JS error:

Error: doc has no properties
Source File: http://creative.gettyimages.com/source/include/globalnav.js
Line: 513

The page has

<script language="JavaScript" type="text/javascript">
	centerLayers();
</script>

and centerLayers does

function centerLayers() {
	var doc = document.layers;
...
Still a problem in Mozilla 1.1 on [RH 6.2] Linux.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20021106

I first went to this web site through a Slashdot article.  Here is a
link to the relevant comment.

http://apple.slashdot.org/comments.pl?sid=42252&cid=4447669

Comment 13

16 years ago
This problem at Gettyone.com probably has something to do with Gates owning so
many images....he probably has some sort of relationship with them.

Comment 14

16 years ago
*** Bug 183547 has been marked as a duplicate of this bug. ***
Summary: dynamic menus misplaced → gettyimages.com - dynamic menus misplaced

Comment 15

16 years ago
*** Bug 184990 has been marked as a duplicate of this bug. ***

Comment 16

16 years ago
Oddly enough the page worked for me using a commercial 12/3 trunk build.
Then when I changed my ua string to Mozilla I saw the problem and when I changed
it back to the Netscape ua the problem still remained. Weird!

I will let Getty know about this. Please do not add any more comments like #13
to this bug. Thanks.

Comment 17

16 years ago
I have contacted Getty as of two months ago.  They said they would look into it
for me and then asked a question which I answered regarding how I viewed it
using a user agent spoofer which allows it to work.  But there was no follow-up
to my answer.  Next time I contacted them and asked how progress was going and
got no answer.

Comment 18

16 years ago
contacted
Status: NEW → ASSIGNED
Whiteboard: [technote needed]

Comment 19

16 years ago
Actually I contacted the Getty Museum which does not own this site. Doh. 

-->doron to contact gettyimages.com
Assignee: susiew → doron
Status: ASSIGNED → NEW

Comment 20

16 years ago
*** Bug 189207 has been marked as a duplicate of this bug. ***

Comment 21

15 years ago
Copy of an email I recently sent to Camino Feedback.  It seems to be a duplicate
of this bug, #170189.  So, I thought I'd post a copy of it here.  Interestingly,
Apple's latest Safari Beta seems to have successfully addressed and corrected
this bug (earlier Safari Betas had also been plagued by this bug...)



Hello Mozilla Team!

I am a daily user of your awesome browser, Camino.  I love OS X and I feel that
Camino, is still the best browser for OS X (even better than the latest Beta of
Safari that includes tabbed browsing.)

In short, keep up the great work -- you have an awesome product.

I work in graphic design.  And, as a large portion of Macintosh (and more
specifically, OS X users) are in the field of graphic design, I thought it
important enough to send along a courtesy email to the dev team regarding a web
site that Camino has difficulty rendering correctly.  Now, I realize that this
issue may be more of a standards problem (i.e. the site not conforming to them);
however, it is such a frequently accessed site among graphic designers (each of
the 30 co-workers in my office access the site several times a day), that I feel
it needs pointing out.

	www.gettyimages.com

	specifically, the navigation on:

	http://creative.gettyimages.com/source/home/home.asp

I can't navigate the site using Camino.

Of all the online Royalty-Free images sites out there, this one is the
"Granddaddy."  We all access this site to do our photography research, and 95%
of all RF photography we use gets purchased from this site.

As of the Camino nightly build of 4/22/03, I still have to switch to IE in order
to be able to navigated the site.  Incidentally, the latest beta of Safari, just
started rendering this site correctly.  (Earlier Safari builds had been plagued
by this problem as well.)

Mozilla 1.3a on OS X is plagued by this same issue.

I'm running OS X 10.2.5.

Warmest regards,
Glenn Watts
tech evang june 2003 reorg
Assignee: doron → english-us
QA Contact: zach → english-us
*** Bug 209351 has been marked as a duplicate of this bug. ***

Comment 24

15 years ago
Here are a few more sites that suffer from similar problems flyout menu
navigation problems under Mozilla. If this not a mozilla bug then why does IE
gracefully handle the page not Mozilla? Just curious...


http://www.iomega.com/na/landing.jsp
http://www.eddiebauer.com/eb/default.asp
http://www.sumaimports.com/m1.shtml

Comment 25

15 years ago
"If this not a mozilla bug then why does IE gracefully handle the page
not Mozilla?"

Standard defense of standards-based browsers follows:

The absence in Mozilla of proprietary "features" of Microsoft Internet
Explorer such as |document.all| is not a bug in Mozilla.  For example,
IE allows HTML pages to embed ActiveX controls, but Mozilla doesn't to
my knowledge.  If a site relies on an ActiveX control, it'll work in
IE but not Mozilla, but that's still not a bug in the implementation
of Mozilla because Mozilla's specification does not include running
ActiveX controls or interpreting VBScript or building a |document.all|
object or anything else IE happens to do.  It's not a bug in the
specification because the drivers who set the specification have chosen
to limit the scope of the Mozilla project to web technologies endorsed
by widely respected organizations such as the World Wide Web Consortium.
The IE DOM is not one of them.  Likewise, it's not within the scope
of Mozilla to support proprietary features of Netscape 4.x such as
|document.layers|.

The bug, if anywhere, is in the site.  If a document is advertised as
a "web page" but does not meet the recognized specification of a "web
page", then the document has a bug.  The Mozilla Tech Evangelism project
(designated in this Bugzilla database by product: Tech Evangelism)
notifies sites of bugs that affect usability in browsers engineered
to follow web standards.

To Gordon Potter:
If you find bugs with other sites, please file separate evangelism bugs.

Comment 26

15 years ago
Their web page appears redesigned.  I think the bug can be closed.

Comment 27

15 years ago
At least it appears fixed if you enter it by www.gettyone.com or
www.gettyimages.com.

Comment 28

15 years ago
*** Bug 214564 has been marked as a duplicate of this bug. ***

Comment 29

15 years ago
Not fixed for me, running mozilla suite 2003091704 on windows 2000.

Steps followed:
1. http://www.gettyimages.com/
2. click 'creative'
3. hover over any item of the line containing 'images', 'film', 'services',
   or 'my account'

Result in Mozilla:
Menu appears centered horizontally and far above that line.

Result in IE 6:
Each menu appears just below the corresponding item in the menu bar.

Get a load of this:

<!-- GETTYONE.COM WINDOWS NETSCAPE STYLE SHEET -->
<link href="/source/include/WinNS4Style.css" type="text/css" rel="stylesheet" />

The site can't even tell the difference between Gecko and NN4.
they attempt to provide a code path but their vendor/version detection is so
convoluted, they end up calling centerLayers() instead of the centerNS6 branch.

Error: doc has no properties
Source File: http://creative.gettyimages.com/source/include/globalnav.js
Line: 534

I'll try to get to this soon and use it as example of how not to write cross
browser dhtml.
Whiteboard: [technote needed] → [technote needed] [how not to example]

Comment 31

15 years ago
this seems to be a case of a bad browser detect, as they're feeding up CSS
called "ns4" to ns4 *and mozilla*, and "ns6" to netscape 6+, safari, and the likes.

*** This bug has been marked as a duplicate of 212874 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.