Closed Bug 1702071 Opened 7 months ago Closed 24 days ago

Fix and re-enable dom/media/webrtc/tests/mochitests/test_peerConnection_basicH264Video.html test on Fission (Windows debug)

Categories

(Core :: WebRTC: Networking, defect, P3)

Unspecified
Windows
defect

Tracking

()

RESOLVED FIXED
94 Branch
Fission Milestone Future
Tracking Status
firefox-esr78 --- wontfix
firefox-esr91 --- wontfix
firefox89 --- wontfix
firefox92 --- wontfix
firefox93 --- wontfix
firefox94 --- fixed

People

(Reporter: cpeterson, Assigned: bwc)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

The dom/media/webrtc/tests/mochitests/test_peerConnection_basicH264Video.html test was disabled for Fission Windows debug in bug 1694828.

[test_peerConnection_basicH264Video.html]
skip-if =
    toolkit == 'android' && is_emulator  # Bug 1355786, No h264 support on android emulator
    fission && debug && os == 'windows'  # Bug 1694828, Initial triage in new task

https://hg.mozilla.org/try/rev/254ded54737a882577b6ffaafd8f2bd9a4d539df#l1.15

Here's a Try run with the perma test failure with many TEST-FAIL messages about expected flaky timeouts and then a test timeout:

https://treeherder.mozilla.org/jobs?repo=try&revision=4810aaf69994f94d946527036635ce2c24ec7f41&selectedTaskRun=eLicu-ERQN6_e7X9f6Ijsg.0

[task 2021-03-29T20:22:06.652Z] 20:22:06     INFO - TEST-FAIL | dom/media/webrtc/tests/mochitests/test_peerConnection_basicH264Video.html | The author of the test has indicated that flaky timeouts are expected.  Reason: WebRTC inherently depends on timeouts 
[task 2021-03-29T20:22:06.652Z] 20:22:06     INFO - Checking outbound-rtp for video track {fd2475c4-29ef-4b16-9089-fa60752f0565} try 59
[task 2021-03-29T20:22:06.652Z] 20:22:06     INFO - Track {fd2475c4-29ef-4b16-9089-fa60752f0565} has 0 packetsSent.
[task 2021-03-29T20:22:06.652Z] 20:22:06     INFO - TEST-FAIL | dom/media/webrtc/tests/mochitests/test_peerConnection_basicH264Video.html | The author of the test has indicated that flaky timeouts are expected.  Reason: WebRTC inherently depends on timeouts 
[task 2021-03-29T20:22:06.652Z] 20:22:06     INFO - Buffered messages finished
[task 2021-03-29T20:22:06.652Z] 20:22:06     INFO - TEST-UNEXPECTED-FAIL | dom/media/webrtc/tests/mochitests/test_peerConnection_basicH264Video.html | Error in test execution: Error: Checking stats for track {ca586e9b-225a-44b0-87bb-2586c261b1f1} timed out after 30000 ms _waitForRtpFlow@https://example.com/tests/dom/media/webrtc/tests/mochitests/pc.js:1820:11 ...  
[task 2021-03-29T20:22:06.652Z] 20:22:06     INFO - SimpleTest.ok@https://example.com/tests/SimpleTest/SimpleTest.js:417:16
[task 2021-03-29T20:22:06.652Z] 20:22:06     INFO - execute/<@https://example.com/tests/dom/media/webrtc/tests/mochitests/head.js:959:11

Byron, the dom/media/webrtc/tests/mochitests/test_peerConnection_basicH264Video.html test perma fails on Windows 10 debug when Fission is enabled. Windows 10 debug without Fission and other platforms with Fission seem to pass reliably.

Do you think fixing this perma test failure for Fission on Windows 10 debug should block shipping Fission MVP?

Flags: needinfo?(docfaraday)

If it is just debug, probably not.

Flags: needinfo?(docfaraday)

(In reply to Byron Campen [:bwc] from comment #2)

If it is just debug, probably not.

Thanks. In that case, I'll mark this bug as not blocking Fission MVP.

That the new failure appears to be a perma fail sounds bad, but it is "just" a test timeout. This test relies on flaky timeouts (by design). Since Fission launches more content processes, it can cause tests to run more slowly or trigger race conditions more easily.

Fission Milestone: ? → Future
Severity: -- → S3
Priority: -- → P3

Depends on D126412

Assignee: nobody → docfaraday
Status: NEW → ASSIGNED
Pushed by bcampen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/583721732aa7
Re-enable this test on windows fission. r=ng
Status: ASSIGNED → RESOLVED
Closed: 24 days ago
Resolution: --- → FIXED
Target Milestone: --- → 94 Branch

Byron, thanks for re-enabling this test for Fission!

I am setting status-firefox93=wontfix because we don't need to uplift this test change to Beta 93.

You need to log in before you can comment on or make changes to this bug.