Closed Bug 1702124 Opened 2 months ago Closed 1 month ago

about:devtools - focus ring of checkbox for GDPR conrifmation truncated when TAB-selected

Categories

(DevTools :: General, defect, P5)

Unspecified
All
defect

Tracking

(firefox-esr78 wontfix, firefox87 wontfix, firefox88 wontfix, firefox89 verified)

VERIFIED FIXED
89 Branch
Tracking Status
firefox-esr78 --- wontfix
firefox87 --- wontfix
firefox88 --- wontfix
firefox89 --- verified

People

(Reporter: cfogel, Assigned: vishal.vikal.88)

References

(Blocks 1 open bug)

Details

(Keywords: good-first-bug, regression)

Attachments

(6 files)

Affected versions

  • 89.0a1(2020-03-28), 88.0b4, 75.0;

Affected platforms

  • Ubuntu 20, Windows 10

Steps to reproduce

  1. Launch Firefox, access about:devtools
  2. Click inside the Email input;
  3. Press the TAB key to select the checkbox for GDPR confirmation;
  • can zoom in for better visibility;

Expected result

  • checkbox highlight is displayed as expected;

Actual result

  • checkbox highlight is cut by the image near it;

Regression range

  • last good: 2019-09-08;
  • first bad: 2019-09-09;
  • pushlog URL;

Additional notes

  • attached screenshot with the issue;
Has Regression Range: --- → no
Has STR: --- → yes
Attached image image.png

Thanks for the report Cristian. I can also reproduce this on Win 10 (screenshot attached).

Also, the registration for Developer Newsletter is currently broken (see bug 1693255)

Honza

Thanks for the input Honza. Have updated the regression section as well in the meanwhile.

Has Regression Range: no → yes
Attached image image (1).png

Attaching a screenshot to illustrate the pre-Proton state (Win10).

Hello Honza,
Can I work on this issue?
Thanks

Please sir response me.
Thanks

Assigned to you, thanks for the help.
Honza

Assignee: nobody → vishal.vikal.88
Status: NEW → ASSIGNED
Attached image checkboximage.png

Fixed Issue Screenshot

Attached image checkboximage2.png

Second screen shot of the fixed issue.

Hello Honza,
I fixed the issue can write the patch for this issue.
Request Information Honza.
Thanks

Hello Sir I fixed the checkbox cut off issue plese review it.

Attachment #9214006 - Attachment description: Bug 1702124 - fix the checkbox cut by the image near it issue. r=Honza → Bug 1702124 - [devtools] Fix the checkbox cut by the image near it issue. r=Honza
Pushed by jodvarko@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c6d2b9780854
[devtools] Fix the checkbox cut by the image near it issue. r=Honza

Hi Vishal,

(In reply to vishal from comment #11)

Hello Honza,
I fixed the issue can write the patch for this issue.

Thank you for the patch I pushed the changes to autoland repo. It's should be merged with the Mozilla Central (m-c) repository soon.

Request Information Honza.

You need to use the fields at the bottom of the page:

  1. Check the "Request information from" checkbox
  2. Insert email of the person you need info from.
  3. Press "Save Changes" just like when you are posting a comment.

Honza

Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch
See Also: → 1703743

The issue is verified fixed in Fx89.0a1 on Windows 10 and Ubuntu 18.04. The button border is no longer cut off.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.