Closed Bug 170213 Opened 18 years ago Closed 16 years ago

Make all static HTML files into page.cgi pages

Categories

(Bugzilla :: Bugzilla-General, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
Bugzilla 2.18

People

(Reporter: gerv, Assigned: gerv)

References

Details

Attachments

(1 file, 9 obsolete files)

Bugzilla currently has the following static HTML files in the root directory:
bug_status.html      helpemailquery.html  notargetmilestone.html  votehelp.html
bugwritinghelp.html  help.html            quicksearchhack.html
confirmhelp.html     how_to_mail.html     quicksearch.html

Translating these files is hard where they are, because there is no possibility
for multiple versions. We should make them into page.cgi pages; this gives them
proper Bugzilla headers and footers, and makes them translatable.

This will also involve changing quite a few links in these documents and others.

Gerv
Plan:

Eliminated as irrelevant/unused (to be CVS removed):
help.html
how_to_mail.html
helpemailquery.html
confirmhelp.html
notargetmilestone.html

Ones I'd like to kill off:
votehelp.html 
(on the basis that this sort of thing should be in the Guide.)

Leave alone for the moment:
quicksearch.html
quicksearchhack.html
on the basis that quicksearch is being rewritten and consultation is necessary.

Templatise:
bug_status.html
bugwritinghelp.html

How does that sound?

Gerv
Matty: bbaetz says you've looked at this issue as part of custres...

Gerv
Myk, bbaetz, dave: I plan to CVS remove the list of files above marked
"Eliminated" quite soon, unless any of you want to step in to save them. 

I also have page.cgi-isations of bug_status.html and bugwritinghelp.html, and
I'll write up that patch in a minute. OK, bug_status may not be part of page.cgi
for ever, but people are wanting to translate it now.

Gerv

Assignee: justdave → gerv
Attached patch Patch v.1 (obsolete) — Splinter Review
This patch page.cgi-ises the Bug Writing Guidelines and the status description
page.

Gerv
Comment on attachment 100520 [details] [diff] [review]
Patch v.1

The 'bug writing help' one is way to bmo specific. I realise that you're just
copying the file in 'as-is', but I don't really see the point, if we're not
going to have a more generic version, or something.
> The 'bug writing help' one is way to bmo specific.

The examples relate to Mozilla - but they have to relate to something, otherwise
they wouldn't be examples. Many sites use only-slightly-modified versions of
these; and putting them in the template directory actually makes this easier,
because they won't get CVS conflicts.

Gerv
Template names fit with new naming scheme?
Yes, they do. I wrote the new (now rather old) naming scheme. :-)

Gerv
help.html, how_to_mail.html, helpemailquery.html, confirmhelp.html and
notargetmilestone.html have been CVS removed.

Gerv
bug_status is going to become a CGI by customised resolutions.

bugwritinghelp was going to become a part of the user documentation that was
planned for bug #109311.
> bug_status is going to become a CGI by customised resolutions.

I'm sure it is - but people want to translate it now. The current system can
always be changed again when the CGI comes along. In fact, there's a pretty
strong chance that by the time we get there, a page.cgi-based solution will work
for enumerating bug statuses.

> bugwritinghelp was going to become a part of the user documentation that was
> planned for bug #109311.

Hmm. We need to discuss whether a Bugzilla installation's doc tree should be
exposed via HTTP and, if so, whether it's appropriate for Bugzilla to link into it.

Gerv
Priority: -- → P3
Summary: Make all static HTML files into page.cgi.pages → Make all static HTML files into page.cgi pages
Target Milestone: --- → Bugzilla 2.18
In bug 215149, I'm working in a kind of, apart what is about here (I would have
created a duplicate if not writing right now). Taking that, where there are
several descs like fields, bugs, resolutions, etc. ready for localization, I
have templatised bug_status.html into bug_status.html.tmpl, and it's only
missing the initial legal stuff.

Any chances for you to take a look? Should I create an attachment?
*** Bug 106612 has been marked as a duplicate of this bug. ***
picking up the dependencies from the duplicate...
Attached file bug_status.html.tmpl (obsolete) —
Attached file bugwritinghelp.html.tmpl (obsolete) —
Attached file quicksearch.html.tmpl (obsolete) —
Attached file quicksearchhack.html.tmpl (obsolete) —
These templates work for me. Maybe only some "legal" stuff should be added.
Well, I've corrected several links inside the attachtments, but to be precise, I
have that at least index.html.tmpl has some links pointing to <file>.html, and
it seems the index.html.tmpl supplied in the 2.17 (and previous) in the tarball
doesn't match the one existing in bmo. I'll keep searching while somebody makes
a suggestion about how to handle this and then I'll provide a patch for the
attachments above, making them obsolete. If it's the first time, just take a
look at them, but be aware they need one more review.
Attachment #130312 - Attachment mime type: application/octet-stream → text/plain
Attachment #130313 - Attachment mime type: application/octet-stream → text/plain
Attachment #130315 - Attachment mime type: application/octet-stream → text/plain
Attachment #130316 - Attachment mime type: application/octet-stream → text/plain
> it seems the index.html.tmpl supplied in the 2.17 (and previous) in the tarball
> doesn't match the one existing in bmo.

Indeed. b.m.o. has a customised front page, and the admins are responsible for
updating it when they move to a version containing this change.

Your attachments are a good start, but templatisation is also an opportunity to
reformat, fix HTML, make pages validate, remove cruft like the "last mod time"
at the bottom of bug_status, make the page names fit with our naming scheme, and
so on. Is there any chance you could give the pages a spring clean? I believe my
patch in this bug did some of that - feel free to use it as a starting point.

For the names, I suggest fields.html.tmpl (as it doesn't just cover statuses),
guidelines.html.tmpl for the bug writing guidelines, quicksearch.html.tmpl and
advanced-quicksearch.html.tmpl . But feel free to suggest other possibilities.

Gerv
Gerv: I've applied your patch, and it's good (well, some rejects, but it could
be my fault).

I'm claiming for a review of code style and variable names of bug 215149, where
I templatize the bug descriptions and other common "key" fields for bz in
global/field-descs.none.tmpl, so I'd rewrite your bug-status-writing.html.tmpl
(for instance) and where it's said (it's an example):

"The bug has the status NEW"

I replace with

"The bug has the status [% bug_status_descs.NEW %]"

which centralizes the status (and other descriptions) avoiding typos and work
time when translating.

This somehow blocks my further work, until somebody corrects or grants the work.
Details of template are in bug 215148
Severity: normal → enhancement
Since bug 215148 seems to be stopped, we could center in just moving the html
files to the pages directory, regardless they need to be rewritten or not.
Gerv: I've moved the four files to the pages directory, have searched for all
occurrences in the template tree and modified for the page.cgi. I have created
the patch using "cvs -q diff -uN", as indicated by Dave, and that's what I've
attached to this bug.

Please do the requests you find necessary if the patch works for you, because
that step wasn't given before and the work has got lost. Theorically, this patch
should make the former obsolete, but since I don't have checkin privs, there
could be something wrong.

If you want me to do something else to fix this bug, please tell me.
Attached patch Patch without checkin privileges (obsolete) — Splinter Review
Forgot to rename bug_status.html
Attachment #140895 - Attachment is obsolete: true
Attachment #140898 - Flags: review?(gerv)
i just forgot to mention that there's a fifth file, votehelp.html, but it has
been always included in the patch, for if you worry about it.
Hmm. The "N" option to diff does not appear to have worked - the new templates
are not in the patch file that you have attached.

The issue is that some of these files really need a rewrite or at least a good
edit. But this also should not hold up this process.

If you email me a tarball of the new files, I will make a proper patch, review
it and check it in after approval has been granted.

Gerv
Attached patch Patch v.2 (obsolete) — Splinter Review
This patch, based on Oscar's work, converts bugwritinghelp.html, votehelp.html
and bug_status.html to page.cgi pages. It also changes all the links to them,
as Oscar's patch did.

It doesn't convert the quicksearch pages, as their future is currently under
discussion.

Gerv
Attachment #100520 - Attachment is obsolete: true
Attachment #130312 - Attachment is obsolete: true
Attachment #130313 - Attachment is obsolete: true
Attachment #130315 - Attachment is obsolete: true
Attachment #130316 - Attachment is obsolete: true
Attachment #140898 - Attachment is obsolete: true
Comment on attachment 141095 [details] [diff] [review]
Patch v.2

Dave: could you review and even approve this? No scary code - it's all simple
stuff. I've made almost no changes to the content - it does need fixing up, but
that's not the point of this bug.

Gerv
Attachment #141095 - Flags: review?(justdave)
Comment on attachment 141095 [details] [diff] [review]
Patch v.2


General comments: I didn't read through the whole text, but through a good deal
of it. I would *really* appreciate it if you wrapped the text at 72 to 78 chars
while you're doing this, because long lines are *very* difficult to review for
me (my browser window is 640px wide). 

You might consider renaming describe-states to describe-status -- for
consistency's sake with the use of "status" pretty much everywhere, and also
because I've found the word "states" tends to remit to geographical "states",
and status is less ambiguous, but it might not be important here.

I assume we're not going to change the keywords (bug, bugzilla, etc) in these
pages, given it't probably not worth the hassle?

Have you ensured that the tests still run with these new templates?

I haven't checked if any links to the old pages are left over, but I guess
you've already grepped for them.

>Index: template/en/default/pages/bug-writing-help.html.tmpl

Check if Eli still maintains this file?

Long lines in this one.

>+[%# INTERFACE:
>+  # This template uses the pages.cgi semi-static display system.
>+  #%]

s/pages.cgi/page.cgi right?

>+++ template/en/default/pages/describe-states.html.tmpl	>+[%# INTERFACE:
>+  # This template uses the pages.cgi semi-static display system.
>+  #%]

Same as in the file above.

>+      The <b>status</B> field indicates the general health 

This is funny, and there are a lot of </B>s and a </DL> or two in this file. If
you feel like lowercasing them, cool.

>Index: docs/sgml/using.sgml
>===================================================================
>RCS file: /cvsroot/mozilla/webtools/bugzilla/docs/sgml/using.sgml,v
>retrieving revision 1.11
>diff -u -r1.11 using.sgml
>--- docs/sgml/using.sgml	27 Jul 2002 22:01:08 -0000	1.11
>+++ docs/sgml/using.sgml	25 Sep 2002 07:25:17 -0000
>@@ -339,7 +339,7 @@
>       <para>Years of bug writing experience has been distilled for your

s/has/have/ been distilled, right?

>Index: docs/html/how.html
>-      While some of the advice is Mozilla-specific, the basic principles of
>-      reporting Reproducible, Specific bugs, isolating the Product you are
>+      These basic principles of
>+      reporting reproducible, specific bugs, isolating the Product you are
>       using, the Version of the Product, the Component which failed, the
>       Hardware Platform, and Operating System you were using at the time of
>       the failure go a long way toward ensuring accurate, responsible fixes

I think the correct wording here would be s/These/The/ making "The basic
principles... go a long way"

>-    Resolve bugs, changing <a href="bug_status.html">resolution</a> to
>+    Resolve bugs, changing <a href="page.cgi?id=describe-states.html">resolution</a> to

shouldn't this have a #status here? I see the anchor in the template at least.

>Index: template/en/default/bug/edit.html.tmpl
>-          <a href="bug_status.html">Status</a>:
>+          <a href="page.cgi?id=describe-states.html">Status</a>:

Same here

>-          <a href="bug_status.html">Resolution</a>:
>+          <a href="page.cgi?id=describe-states.html">Resolution</a>:

Same here

>-      Resolve bug, changing <a href="bug_status.html">resolution</a> to
>+      Resolve bug, changing <a href="page.cgi?id=describe-states.html">resolution</a> to

Same here

>Index: quicksearchhack.html
>-  <td><a href="bug_status.html">Status</a> 
>+  <td><a href="page.cgi?id=describe-states.html">Status</a> 

Same here

>-  <td><a href="bug_status.html">Resolution</a></td>
>+  <td><a href="page.cgi?id=describe-states.html">Resolution</a></td>

And here

>-    print "  <TH ALIGN=\"right\">Number of votes a bug in this product needs to automatically get out of the <A HREF=\"bug_status.html#status\">UNCONFIRMED</A> state:</TH>\n";
>+    print "  <TH ALIGN=\"right\">Number of votes a bug in this product needs to automatically get out of the <A HREF=\"page.cgi?id=describe-states.html#status\">UNCONFIRMED</A> state:</TH>\n";

... maybe only because we do it here. :-) I guess this is only important if you
want to take advantage of the fact that you already have your hands dirty
anyway.

Assuming this is the way we want to go (templatizing all static HTML), r=kiko
and address the above as you see fit.
Attachment #141095 - Flags: review?(justdave) → review+
Oh, pants.

I've attached the wrong patch. This is the one from six months ago! Aargh!

I feel a right idiot.

Gerv
Attached patch Patch C v.1 (obsolete) — Splinter Review
<looks sheepish> The correct patch.

Gerv
Attachment #141095 - Attachment is obsolete: true
Comment on attachment 141223 [details] [diff] [review]
Patch C v.1

Sorry again...

Gerv
Attachment #141223 - Flags: review?(kiko)
REDRUM REDRUM REDRUM
Red Rum the racehorse? Or Re-drum as in "hit the drum again"? 

Gerv
REDRUM as in MURDER backwards. I take it you've never seen The Shining?
No; my cultural education is obviously sorely lacking.

What can I do but apologise again? :-|

Gerv
Attachment #140898 - Flags: review?(gerv)
Oh, I was joking -- it's obviously not a big deal. I'll try looking at this
later today, back in office (finally).
Comment on attachment 141223 [details] [diff] [review]
Patch C v.1


This came out a bit fussier than I hoped, so feel free to take into account as
much as you like here. You might want to read this comment backwards as I
started at the last file and worked up.

Issues:

  - #bug_severity is linked to, but doesn't exist (#severity does though)
  - #status isn't used in some places
  - #resolution doesn't exist, what to do?

If you want to run the pages through the validator before checking them in, you
might catch an error or two. I don't think HTML fixes of the sort require
additional reviews given that these pages are really non-critical :-)

Feel free to request approval when you've banged this up as much as you think
is necessary.

>Index: template/en/default/bug/edit.html.tmpl
>===================================================================
>@@ -205,14 +205,14 @@
>     <tr>
>       <td align="right">
>         <b>
>-          <a href="bug_status.html">Status</a>:
>+          <a href="page.cgi?id=fields.html">Status</a>:
>         </b>
>       </td>
>       <td>[% bug.bug_status FILTER html 

#status?

>@@ -220,7 +220,7 @@
>     <tr>
>       <td align="right">
>         <b>
>-          <a href="bug_status.html">Resolution</a>:
>+          <a href="page.cgi?id=fields.html">Resolution</a>:
>         </b>
>       </td>
>       <td>

#status?

>Index: template/en/default/bug/knob.html.tmpl
>===================================================================
>RCS file: /cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/knob.html.tmpl,v
>retrieving revision 1.2
>diff -u -r1.2 knob.html.tmpl
>--- template/en/default/bug/knob.html.tmpl	18 Jan 2004 18:39:18 -0000	1.2
>+++ template/en/default/bug/knob.html.tmpl	10 Feb 2004 23:31:54 -0000
>@@ -59,7 +59,8 @@
>       [% END %]
> 
>       <input type="radio" name="knob" value="resolve">
>-      Resolve [% terms.bug %], changing <a href="bug_status.html">resolution</a> to
>+      Resolve [% terms.bug %], changing 
>+      <a href="page.cgi?id=fields.html">resolution</a> to

Want #status?

>Index: template/en/default/bug/create/create.html.tmpl
>       </strong>
>     </td>
>     <td colspan="3">
>@@ -331,7 +331,8 @@
>   [% IF sel.description %]
>   <td align="right">
>     <strong>
>-      <a href="bug_status.html#[% sel.name %]">[% sel.description %]</a>:
>+      <a href="page.cgi?id=fields.html#[% sel.name %]">
>+        [% sel.description %]</a>:
>     </strong>
>   </td>
>   [% END %]

I checked and there's a problem here. The name of the anchor that will be used
here is bug_severity, but the anchor in fields.html is severity. I think the
easiest is to fix occurences/links from severity to bug_severity..

>Index: template/en/default/list/edit-multiple.html.tmpl
>@@ -266,7 +266,7 @@
>   [% knum = knum + 1 %]
>   <input id="knob-resolve" type="radio" name="knob" value="resolve">
>   <label for="knob-resolve">
>-    Resolve [% terms.bugs %], changing <a href="bug_status.html">resolution</a> to
>+    Resolve [% terms.bugs %], changing <a href="page.cgi?id=fields.html">resolution</a> to

Does this want #status?

>Index: editproducts.cgi

Five bucks to whoever templatizes this..

>Index: quicksearchhack.html
>@@ -79,7 +79,7 @@
>   <td rowspan="2"><tt>UNCO,NEW,...,CLOS,<br>FIX,DUP,...<i>(as first word)</i></tt></td>
>   <td><tt>status</tt></td>
>   <td>&nbsp;</td>
>-  <td><a href="bug_status.html">Status</a> 
>+  <td><a href="page.cgi?id=fields.html">Status</a> 
>       <i>("bug_status")</i>
>   </td>
> </tr>
>@@ -87,35 +87,35 @@
>   <td>&nbsp;</td>
>   <td><tt>resolution</tt></td>
>   <td>&nbsp;</td>
>-  <td><a href="bug_status.html">Resolution</a></td>
>+  <td><a href="page.cgi?id=fields.html">Resolution</a></td>


These links should have at least a #status here. I know we don't have a
#resolution -- should we?

I'll repost my question: I assume we're not going to change the keywords (bug,
bugzilla, etc) in these pages, given it't probably not worth the hassle?
Attachment #141223 - Flags: review?(kiko) → review+
Attached patch Patch C v.2Splinter Review
Kiko's issues addressed. It also now passes tests.

Gerv
Attachment #141223 - Attachment is obsolete: true
Requesting approval.

Gerv
Flags: approval?
Flags: approval? → approval+
Fixed.

Checking in template/en/default/pages/voting.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/pages/voting.html.tmpl,v
 <--  voting.html.tmpl
initial revision: 1.1
done
RCS file:
/cvsroot/mozilla/webtools/bugzilla/template/en/default/pages/fields.html.tmpl,v
done
Checking in template/en/default/pages/fields.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/pages/fields.html.tmpl,v
 <--  fields.html.tmpl
initial revision: 1.1
done
RCS file:
/cvsroot/mozilla/webtools/bugzilla/template/en/default/pages/bug-writing.html.tmpl,v
done
Checking in template/en/default/pages/bug-writing.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/pages/bug-writing.html.tmpl,v
 <--  bug-writing.html.tmpl
initial revision: 1.1
done
Checking in template/en/default/bug/edit.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/edit.html.tmpl,v  <--
 edit.html.tmpl
new revision: 1.40; previous revision: 1.39
done
Checking in template/en/default/bug/knob.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/knob.html.tmpl,v  <--
 knob.html.tmpl
new revision: 1.3; previous revision: 1.2
done
Checking in template/en/default/bug/create/create.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/create/create.html.tmpl,v
 <--  create.html.tmpl
new revision: 1.27; previous revision: 1.26
done
Checking in template/en/default/bug/create/user-message.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/create/user-message.html.tmpl,v
 <--  user-message.html.tmpl
new revision: 1.4; previous revision: 1.3
done
Checking in template/en/default/bug/votes/list-for-user.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/votes/list-for-user.html.tmpl,v
 <--  list-for-user.html.tmpl
new revision: 1.13; previous revision: 1.12
done
Checking in template/en/default/list/edit-multiple.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/list/edit-multiple.html.tmpl,v
 <--  edit-multiple.html.tmpl
new revision: 1.14; previous revision: 1.13
done
Checking in editproducts.cgi;
/cvsroot/mozilla/webtools/bugzilla/editproducts.cgi,v  <--  editproducts.cgi
new revision: 1.45; previous revision: 1.44
done
Checking in quicksearchhack.html;
/cvsroot/mozilla/webtools/bugzilla/quicksearchhack.html,v  <--  quicksearchhack.html
new revision: 1.5; previous revision: 1.4
done

Gerv
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Didn't you forget to remove the html files from the root dir?
Yep. I was thinking of adding redirects, but no-one externally links to the
b.m.o. versions, so there's no need.

Gerv
Removing bugwritinghelp.html;
/cvsroot/mozilla/webtools/bugzilla/bugwritinghelp.html,v  <--  bugwritinghelp.html
new revision: delete; previous revision: 1.3
done
Removing votehelp.html;
/cvsroot/mozilla/webtools/bugzilla/votehelp.html,v  <--  votehelp.html
new revision: delete; previous revision: 1.10
done
Removing bug_status.html;
/cvsroot/mozilla/webtools/bugzilla/bug_status.html,v  <--  bug_status.html
new revision: delete; previous revision: 1.16
done

Gerv
Are you leaving quicksearchhack.html and quicksearch.html for a later stage? At
this time (not sure if because of this bug) cvs is broken because
global/descs.none.tmpl is missing.
The breakage isn't this bug.

Yes, I've left QuickSearch; it's currently being redesigned in a whole bunch of
bugs filed by afranke, so it wasn't worth it.

Gerv
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.