Windows XP trashes Mail/News profile database

RESOLVED INVALID

Status

()

Core
Preferences: Backend
RESOLVED INVALID
16 years ago
16 years ago

People

(Reporter: Mark Petryk, Assigned: Bill Law)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Regularly the Mail/News component looses its profile information completely. 
The only solution is to completely reload all mail account and news account
manually.  This only happens on Windows XP with the Mozilla 1.2a version.

Comment 1

16 years ago
you're saying prefs.js gets lost/crunched? that's not a mail/news bug. It's a
dup, though it was supposed to have been fixed before 1.2a
(Reporter)

Comment 2

16 years ago
I don't know what gets crunched.  I'm new to bugzilla, but I would be happy to
research it for you, if you can tell me what to look for (I'm a programmer from
the old CP/M days - don't be afraid to send me hunting).  I cannot keep Moz
running for even a day.  Within hours all the news/profile information is blank.
 Clicking on the "Mail & Newsgroups" button on the bottom left causes a prompt
for "Email" or "Newsgroup" like I've never been there before.

I just installed XP SP1 on the rumor that this patch was suppose to be more "3rd
party app friendly".  The patch fixed my networking-to-samba problems, but Moz
is still acting the same.

I did my best to search the bugzilla for anything related and found nothing. 
Hope I'm not causing you duplicate efort.

Comment 3

16 years ago
bug 155080 is the one I'm thinking of.

Do you shutdown and restart the app, or is the profile information lost while
the app is running? Do you have quicklaunch turned on? I believe it's turned on
by default; you could try turning it off with Edit | Preferences | Advanced -
again, I thought this was supposed to have been fixed, but if you read the
comments in that bug, you'll see that they went round and round trying to fix it.
(Reporter)

Comment 4

16 years ago
Wow! They sure did go round and round on that bug.  This one sounds very similar
- if not identical.  I have not paid attention to whether I had QL on or not. 
Based on what I just finished reading I'll expiriment and let you know.

Prior to this I have been running winME and I never saw the problem.  I don't
remember if I was on the latest Moz, I think it was just one release back from 1.2a.
(Reporter)

Comment 5

16 years ago
Yes, prefs.js is getting reset to nothing (or very little), loosing all my mail
setups.  This happens with QL or no QL.  I completely shut down the app, and
then restart it.  It takes about 5 or 6 attempts to loose the contents of
prefs.js.  I make sure everything has stopped hour-glassing before relaunching
Moz.  It does not appear to be tied to QL in any way, as far as I can detect.
(Reporter)

Comment 6

16 years ago
Just installed Moz 1.0 which may have been the version I was running before I
switched to XP *and* the Moz 1.2a version as well.  I'll let you know if I spot
the problem here, but if memory serves, I hadn't seen it on 1.0 before.

Comment 7

16 years ago
Mark, when you shutdown mozilla, how long do you wait before restarting it? The
bug  was that if you restarted it while it was still in the process of shutting
down (which can continue past the point that all the windows are closed), then
you could lose your prefs.js. All sorts of bullet-proofing was put in to prevent
that, but I'm wondering if that's still broken. Or if for some reason, the app
hasn't really shut down. You could check this out with the windows task manager.
(Reporter)

Comment 8

16 years ago
I waited... a bit.  I noticed that when the QL was running, Moz would shut down,
and then QL would relaunch - or something.  QL was always running, until I
closed Moz then the QL would quit and then restart.  I pretty much waited for
everything to quit before launching again.

Also, I noticed that when Moz is shutting down, and the QL is being relaunched,
Moz will not launch from the short cut, until after QL seems to be up and running.

Without QL, I waited short and waited long.  There didn't seem to be a direct
correlation between how long I waited before restarting.  Understanding the
issue somewhat I tried to aggrevate it by restarting quickly.  This didn't seem
to have an impact on the lost prefs.js file.  Again, the prefs.js file was lost
with and without QL.  When it was lost, I can't say as I remember whether I
restarted quickly or not.  I will continue to test.

Comment 9

16 years ago
If QuickLaunch is turned on, Mozilla never really shuts down. Do you have
multiple profiles? (I believe that affects how QL works). I'm going to reassign
this to one of the prefs people (whoever worked on bug 155080)
Component: Mail Database → Preferences: Backend
Product: MailNews → Browser

Comment 10

16 years ago
-> law, cc ccarlen. It's up to you guys if you want to re-open bug 155080 or
just use this new bug.
Assignee: bienvenu → law
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 11

16 years ago
I have one profile.
(Reporter)

Comment 12

16 years ago
Woa!  Back on Moz 1.0 I just lost the same prefs.js file.  This is on XP though
- I've not seen it, like I said, on ME.  Are you sure this isn't an XP issue? 
I'm not running QL, and it's been very long between Moz launches.

Updated

16 years ago
QA Contact: gayatri → esther
(Reporter)

Comment 13

16 years ago
Moz 1.0, still dropping prefs.js, hours between Moz launches.  No QL running. 
Windows XP, with SP1.
(Reporter)

Comment 14

16 years ago
Update: I just found a strange problem with this (new) Sony portable and XP and
PcCillin (shipped-with virus scanner).  The virus scanner went haywire and
started causing all sorts of system problems, mostly around launching programs.
 I've disabled the scanner and now the PC seems to be back to normal.  This
*may* have impacted Mozilla somehow.  I'm back at 1.2a and am continuing my
testing of that version, and I'll let ya'll know if I still see problems, or
I'll let you know if in a week or so I don't.
(Reporter)

Comment 15

16 years ago
24 hours of Moz 1.2a and no more problems... My original problem may, in fact,
have been due to the problems exaserbated by PcCillin.  PcCillin is no longer
running and the machine is running fine along with Mozilla... just like it was
on ME.  Another day or two like this and I'd say this was a fales alarm.  Sorry
for the inconvenience.  I let you know!
(Reporter)

Comment 16

16 years ago
1.2a has not crashed all week since removing PcCillin.  Closing the bug.  Sorry
for the distraction.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.