Closed Bug 1702264 Opened 8 months ago Closed 8 months ago

Heartbeat Infobar is multiplied when Proton is enabled

Categories

(Toolkit :: General, defect, P2)

defect

Tracking

()

VERIFIED FIXED
Tracking Status
firefox87 --- unaffected
firefox88 --- unaffected
firefox89 --- verified
firefox90 --- verified

People

(Reporter: simona.marcu, Unassigned)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [proton-infobars] [priority:2a])

Attachments

(1 file)

Attached image MultipliedInfobarjpeg

Affected platforms:
Ubuntu 20.04
macOS Big Sur 11.1
Windows 10, 7

Affected versions:
Nightly 89.0a1

Steps to reproduce:

  1. Launch Firefox.
  2. Go to about:config and set the following preferences to true: browser.proton.enabled,
    browser.proton.infobars.enabled - do not restart just yet.
  3. Go to about:profiles and open the profile directory folder.
  4. Download the user.js file from the Here and copy it into the profile directory
  5. Restart your browser (used Cmd+Shift+J and then Cmd+option+R)
  6. After the Heartbeat Infobar is triggered, wait for a while (at least 15 minutes).

Expected Result:
The Heartbeat Infobar should properly remain opened.

Actual Results:
The Heartbeat Infobar multiplies after approximately 15 minutes (doubled after 15 minutes and tripled in approximately 2h).

Notes:
The issue is not reproducible on the latest Nightly 89.0a1 when Proton is not enabled (the preferences browser.proton.enabled and browser.proton.infobars.enabled are set to false).

Whiteboard: [proton-infobars]
Component: Messaging System → General
Product: Firefox → Toolkit

Should be fixed by bug 1702327.

Actually, looking at the code I'm not sure this will be fixed.

Simona, in the non-proton case is there only one heartbeat bar or does dismissing one reveal another underneath it?

Flags: needinfo?(simona.marcu)
Priority: -- → P2
Whiteboard: [proton-infobars] → [proton-infobars] [priority:2a]

(In reply to Mark Striemer [:mstriemer] from comment #2)

Actually, looking at the code I'm not sure this will be fixed.

Simona, in the non-proton case is there only one heartbeat bar or does dismissing one reveal another underneath it?

If I dismiss the Heartbeat Infobar by clicking on the "X" button, then there is no other infobar revealed underneath. But, if I click on the "Take Survey" button, then I see a new Infobar with the text string "Thanks!" that will auto-dismiss after in 2-3 seconds. https://imgur.com/ZXhA5eK

Flags: needinfo?(simona.marcu)

Simona, can you grab the file shield-recipe-client.json from a profile that has seen this bug happen, and then been shut down?

Flags: needinfo?(simona.marcu)

Michael, I can no longer reproduce the multiplying behavior on the latest Nightly 89.0a1 (20210411210108).

Flags: needinfo?(simona.marcu)

I think this was likely fixed by bug 1702327 then. I couldn't find anything that would trigger this multiple times and it was previously erroring out so this seems like it could've been triggered by that.

Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED

Verified as fixed using the latest Firefox 89 beta 2 and the latest Nightly 90.0a1 - the Heartbeat Infobar is no longer multiplying. Verified on macOS BigSur 11.2, Ubuntu 20.04, and Windows 10 x64.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.