If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

command line args are missing for mail news and others in --help

VERIFIED INVALID

Status

Core Graveyard
Cmd-line Features
VERIFIED INVALID
15 years ago
9 years ago

People

(Reporter: jg, Unassigned)

Tracking

Other Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

command line args are missing for mail news and others in help

Reproducible: Always

Steps to Reproduce:
1. mozila --help
2.
3.

Actual Results:  
ozilla options
        -height <value>         Set height of startup window to <value>.
        -h or -help             Print this message.
        -installer              Start with 4.x migration window.
        -width <value>          Set width of startup window to <value>.
        -v or -version          Print /usr/lib/mozilla-1.1/mozilla-bin version.
        -CreateProfile <profile>                Create <profile>.
        -P <profile>            Start with <profile>.
        -ProfileWizard          Start with profile wizard.
        -ProfileManager         Start with profile manager.
        -SelectProfile          Start with profile selection dialog.
        -UILocale <locale>              Start with <locale> resources as UI Locale.
        -contentLocale <locale>         Start with <locale> resources as content
Locale.
        -remote <command>       Execute <command> in an already running
                                Mozilla process.  For more info, see:

                http://www.mozilla.org/unix/remote.html

        -splash         Enable splash screen.
        -jsconsole              Start with Javascript Console
        -edit <url>             Start with editor.
        -chrome <url>           Load the specified chrome.

Expected Results:  
 
-mail
-news
etc
Worksforme in a current Linux build.  -mail and -compose come after -chrome,
while -addressbook and -news come after -splash.  Did you install mailnews?  The
options are not there in help if mailnews is not installed...

(over to something like the right component).
Assignee: asa → oeschger
Component: Browser-General → Help
QA Contact: asa → tpreston
(Reporter)

Comment 2

15 years ago
Just checking
if i type /usr/bin/mozilla --help they are there


Mozilla options
        -height <value>         Set height of startup window to <value>.
        -h or -help             Print this message.
        -installer              Start with 4.x migration window.
        -width <value>          Set width of startup window to <value>.
        -v or -version          Print /usr/lib/mozilla-1.1/mozilla-bin version.
        -CreateProfile <profile>                Create <profile>.
        -P <profile>            Start with <profile>.
        -ProfileWizard          Start with profile wizard.
        -ProfileManager         Start with profile manager.
        -SelectProfile          Start with profile selection dialog.
        -UILocale <locale>              Start with <locale> resources as UI Locale.
        -contentLocale <locale>         Start with <locale> resources as content
Locale.
        -remote <command>       Execute <command> in an already running
                                Mozilla process.  For more info, see:

                http://www.mozilla.org/unix/remote.html

        -splash         Enable splash screen.
        -addressbook            Start with the addressbook.
        -news           Start with news.
        -jsconsole              Start with Javascript Console
        -edit <url>             Start with editor.
        -chrome <url>           Load the specified chrome.
        -mail           Start with mail.
        -compose <url>          Start with messenger compose.

but

/usr/lib/mozilla-1.1/mozilla-bin --help does not list them, this is listed in
the --help above as the binary name.

Why are there 2 different binaries with different --help?

Regards

JG
"mozilla-bin" is a binary.  "mozilla" is a script that sets some environment
variables and runs "mozilla-bin", passing through command-line args.  If the
variables are not set, mozilla-bin does not know where to look for various
libraries, including the mailnews libraries.  This has two effects:

1)  It segfaults right after giving the help output
2)  The help output does not include any options that are registered by
    non-browser modules, since those modules didn't get located.

If you just set MOZILLA_FIVE_HOME and/or LD_LIBRARY_PATH correctly by hand,
mozilla-bin will give you the same output as mozilla.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 4

15 years ago
I think command line options do need documented in either the release notes or
Help.  They are online, but that isn't too helpful when you are offline.
Severity: trivial → normal
Status: RESOLVED → UNCONFIRMED
Component: Help → User
OS: Linux → All
Product: Browser → Documentation
Hardware: PC → All
Resolution: INVALID → ---
Version: Trunk → unspecified
You mean like in the "point and click" help?  Why??  Anyone looking for
command-line options would try --help off the command line like for any other
commandline program....  People looking at point-and-click help typically
point-and-click to launch their web browser too.

What am I missing?

Comment 6

15 years ago
Because not all people would know that --help gives command line options and I
don't think it gives options in Windows (at least not when Mozilla is already
running) so the options need documented somewhere.  Also, some things can be
started from the command line which can't be started from the Start Up options.
Um.  Till you went and mucked with it, this was a LINUX-ONLY (since --help is
platform specific) bug.  It was even filed on the right component. 

Go ahead and file a bug on other platforms if their --help impls are broken. 
Don't mutate bugs.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → INVALID

Comment 8

15 years ago
vrfy invalid
Status: RESOLVED → VERIFIED
Component: User → XP Apps: Cmd-line Features
OS: All → Linux
Product: Documentation → Browser
Hardware: All → PC
Summary: command line args are missing for mail news and others in help → command line args are missing for mail news and others in --help
Version: unspecified → Other Branch

Updated

9 years ago
Assignee: oeschger → nobody
Component: Cmd-line Features → Cmd-line Features
Product: Core → Core Graveyard
QA Contact: tpreston → cmd-line
You need to log in before you can comment on or make changes to this bug.