Open Bug 1702548 Opened 8 months ago Updated 6 months ago

White line under tabs with custom theme and Proton enabled

Categories

(Firefox :: Theme, defect, P2)

defect

Tracking

()

People

(Reporter: mconca, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-tabs-bar] [priority:2c])

Attachments

(2 files)

Attached image image.png

When browser.proton.enabled=true I have a white line between the tab strip and the nav/URL strip with my custom theme. See attachment.

Confirmed that this does not happen when proton pref is set to false. Switching to a built-in theme (dark, light, default) and then back to custom theme does not clear it. Perhaps related, there is very little differentiation between my active tab and the other tabs, only a very thin outline (no fill difference). In the attachement, the third pinned GMail tab is active.

Nightly 89. Theme I'm using is from AMO: Wine Abstract Light

Component: Themes → Theme
Product: Toolkit → Firefox
Whiteboard: [proton-tabs-bar]

I don't see the white line in my test profile, so there might be other Proton prefs at play there. The active tab issue seems to be bug 1697448, which was closed as fixed. Maybe ntim can confirm that we're okay with the current solution?

Priority: -- → P2
Whiteboard: [proton-tabs-bar] → [proton-tabs-bar] [priority:2c]

Circling back on this, bug 1702329 should address the low visibility of the active tab. So this bug should probably just be about the white line (needs clearer STR).

Attached video theme.mp4

STR:

  1. Create a new profile (NIghtly)
  2. Open about:addons
  3. Click on Themes (probably not strictly necessary)
  4. Search for "Wine Abstract LIght" theme in the search box
  5. Install that theme (click OK to acknowledge the panel)

White line should appear below tabs. See attached video of these steps.

A similar report is at https://github.com/mozilla/FirefoxColor/issues/977
According to the reporter:

If it's possibly relevant as well I'm on Windows and all my monitors are set to 1440p.

Mike, what's your screen resolution and pixel density?

A potential explanation is that there is an unfavorable rounding error that results in an empty/blank/white/gray line.

Duplicate of this bug: 1706714

(In reply to Rob Wu [:robwu] from comment #4)

A similar report is at https://github.com/mozilla/FirefoxColor/issues/977
According to the reporter:

If it's possibly relevant as well I'm on Windows and all my monitors are set to 1440p.

Mike, what's your screen resolution and pixel density?

I can still reproduce this in today's Fx91 Nightly build. I'm on Windows 10, and my display is a Dell U3415W currently set to its native resolution of 3440x1440 (scaling set to default 100%).

You need to log in before you can comment on or make changes to this bug.