Eliminate dead code from layout to reduce footprint

RESOLVED DUPLICATE of bug 121881

Status

()

P1
normal
RESOLVED DUPLICATE of bug 121881
19 years ago
5 years ago

People

(Reporter: sfraser_bugs, Assigned: kmcclusk)

Tracking

({memory-footprint, perf})

Trunk
Future
memory-footprint, perf
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Startup data show that loading the layout DLL is a significant proportion of
startup time; on Mac, this DLL is around 4Mb in size, and takes about 0.3 of a
second to load on a very fast machine. On slower machines, it could take over a
second.

There is apparently some code in layout that could be removed, or at least
#ifdeffed out. An example is the native form control frames, which could be
removed if we remove the dependency of viewer on native widgets.

So this bug should be used for dead code tracking and removal.

Comment 1

19 years ago
Kevin, would you be the right person to own the ifdefing out of native widgets
from gecko?
(Assignee)

Updated

19 years ago
Assignee: nisheeth → kmcclusk
(Assignee)

Comment 2

19 years ago
I think we need to add a define which which we will use to keep the native
widget frames and widgets in the debug build, but removes them from the release
build.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M13
(Assignee)

Updated

19 years ago
Target Milestone: M13 → M14
(Assignee)

Comment 3

19 years ago
Moving to M14
(Assignee)

Updated

19 years ago
Assignee: kmcclusk → rods
Status: ASSIGNED → NEW
(Assignee)

Comment 4

19 years ago
Reassigning to Rod

Updated

19 years ago
Keywords: perf
Summary: [Perf] Eliminate dead code from layout to reduce footprint → Eliminate dead code from layout to reduce footprint

Comment 5

19 years ago
*** Bug 14819 has been marked as a duplicate of this bug. ***

Comment 6

19 years ago
The extra widget classes have been removed from the windows dir.

Comment 7

19 years ago
I have removed all unneeded widget classes (except those needed by the viewer) 
the viewer required classes need to be moved to the viewer directory.

moving to M15
Target Milestone: M14 → M15
(Reporter)

Comment 8

19 years ago
rods: is your code removal XP, or just Windows? This bug should only be 
considered fixed when it's been done XP.

Comment 9

19 years ago
My changes are for Windows, I figured I would reassign it to waqar or pink.
Status: NEW → ASSIGNED

Comment 10

19 years ago
nsLabel, nsButton, nsCheckButton, nsTextWidget, nsTextHelper have been removed 
from the widget factory and are not part of the viewer build (on Windows)

Now I need to move th Interfaces over and I will be able to hand the bug off.

Comment 11

19 years ago
mass-move to M16
Target Milestone: M15 → M16

Comment 12

19 years ago
Moving out by executive order.
Target Milestone: M16 → M17

Comment 13

19 years ago
This is mostly cleanup work that has to do with the viewer and the widget 
library setting to "future"
Target Milestone: M17 → Future

Comment 14

18 years ago
Waqar, I am assigning this to you to fix Linux and Mac. It is fixed on Windows. 
The native widgets needs to be moved from the widget/src/<platform> directory to  
webshell/tests/viewer/<platform> directory and then the builds changed.

Check out the directory webshell/tests/viewer/windows and you will see what 
files need to be moved (approximently). Call me if you have any questions.
Assignee: rods → waqar
Severity: normal → major
Status: ASSIGNED → NEW
Priority: P3 → P1
Target Milestone: Future → ---
(Assignee)

Comment 15

18 years ago
Added footprint keyword
Keywords: footprint
Keywords: donttest
(Assignee)

Comment 16

18 years ago
Set milestone to mozilla0.8
Target Milestone: --- → mozilla0.8

Comment 17

18 years ago
Working on it.
Status: NEW → ASSIGNED

Comment 18

18 years ago
Almost working, the code from widget directory has been removed but the viewer is 

having problem, I need to add some more methonds to the native widgets.

Target Milestone: mozilla0.8 → mozilla0.9
(Assignee)

Updated

18 years ago
Target Milestone: mozilla0.9 → mozilla0.9.1
(Assignee)

Comment 19

18 years ago
Taking this bug
Assignee: waqar → kmcclusk
Status: ASSIGNED → NEW
(Assignee)

Updated

18 years ago
OS: Mac System 8.5 → Linux
Target Milestone: mozilla0.9.1 → mozilla0.9.3

Updated

18 years ago
Target Milestone: mozilla0.9.3 → mozilla0.9.4
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.4 → mozilla0.9.5
(Assignee)

Comment 20

17 years ago
Moving to Mozilla0.9.6
Target Milestone: mozilla0.9.5 → mozilla0.9.6
(Assignee)

Updated

17 years ago
Severity: major → normal
Target Milestone: mozilla0.9.6 → mozilla1.0

Updated

17 years ago
Blocks: 104669
(Assignee)

Comment 21

17 years ago
I think the solution is to re-write the viewer test app so it doesn't use any
native widgets then we can remove the remaining code from our GTK implementation
to reduce footprint.
Status: NEW → ASSIGNED
Target Milestone: mozilla1.0 → mozilla0.9.9
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.9 → mozilla1.0.1
(Assignee)

Comment 22

17 years ago
Bulk moving Mozilla1.01 bugs to future-P1. I will pull from the future-P1 list
to schedule bugs for post Mozilla1.0 milestones
Target Milestone: mozilla1.0.1 → Future

Updated

16 years ago
OS: Linux → All

Updated

16 years ago
Blocks: 191033

Comment 23

16 years ago
should this be dupped against http://bugzilla.mozilla.org/show_bug.cgi?id=139911 ?
(Assignee)

Comment 24

16 years ago
Probably want to keep this as a separate bug.

Once the fix for bug 139911 lands it will allow us to remove the native widgets.
 So this bug should be marked dependent on bug 139911.
Depends on: 139911
alecf, jkeiser, isn't this what you're sorta doing right now anyway?

Comment 26

12 years ago
(In reply to comment #24)
> Probably want to keep this as a separate bug.
> 
> Once the fix for bug 139911 lands it will allow us to remove the native widgets.
>  So this bug should be marked dependent on bug 139911.

bug 139911 was done in 2003 ... is this bug still valid?

Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 121881
You need to log in before you can comment on or make changes to this bug.