Closed Bug 1702934 Opened 6 months ago Closed 2 months ago

Port |Bug 462681 - mailWindowOverlay.js style/whitespace/indention/comment/linewrap cleanup. And some function simplifications| to SeaMonkey

Categories

(SeaMonkey :: MailNews: Message Display, task)

Tracking

(seamonkey2.53+ fixed)

RESOLVED FIXED
seamonkey 2.89
Tracking Status
seamonkey2.53 + fixed

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

Details

(Whiteboard: SM2.53.9)

Attachments

(2 files, 2 obsolete files)

Port the relevant parts of the following bugs to SeaMonkey:

  • Bug 462681 - mailWindowOverlay.js style/whitespace/indention/comment/linewrap cleanup. And some function simplifications
  • Bug 492501 - Unable to get next 500 news messages in newsgroups
Attached patch 1702934-port462681-2538.patch (obsolete) — Splinter Review

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: none
Testing completed (on m-c, etc.): 2.53.8
Risk to taking this patch (and alternatives if risky): none
String changes made by this patch: none

Attachment #9213506 - Flags: review?(frgrahl)
Attachment #9213506 - Flags: approval-comm-release?
Attachment #9213506 - Flags: approval-comm-esr60?

Unbitrotted patch

Attachment #9213506 - Attachment is obsolete: true
Attachment #9213506 - Flags: review?(frgrahl)
Attachment #9213506 - Flags: approval-comm-release?
Attachment #9213506 - Flags: approval-comm-esr60?
Attachment #9232996 - Flags: review?(frgrahl)
Attachment #9232996 - Flags: approval-comm-release?
Attachment #9232996 - Flags: approval-comm-esr60?

Comment on attachment 9232996 [details] [diff] [review]
1702934-port462681-2539.patch

LGTM

Attachment #9232996 - Flags: review?(frgrahl)
Attachment #9232996 - Flags: review+
Attachment #9232996 - Flags: approval-comm-release?
Attachment #9232996 - Flags: approval-comm-release+
Attachment #9232996 - Flags: approval-comm-esr60?
Attachment #9232996 - Flags: approval-comm-esr60+
Attached patch 1702934-2-2539.patch (obsolete) — Splinter Review

As discussed. The file is now halfway formatted after pthe first part but full of inconsistencies. Ran it thru the linter and adjusted one case manually where indention in one function was still 4 blanks.

[Approval Request Comment]
Regression caused by (bug #): nothing
User impact if declined: developer becomes unhappy when seeing the source without it.
Testing completed (on m-c, etc.): 2.53.9b1 pre
Risk to taking this patch (and alternatives if risky): Formatting only.
String changes made by this patch: --

Attachment #9234157 - Flags: review?(iann_bugzilla)
Attachment #9234157 - Flags: approval-comm-release?
Attachment #9234157 - Flags: approval-comm-esr60?

Comment on attachment 9234157 [details] [diff] [review]
1702934-2-2539.patch

[Triage Comment]
Neat r/a=me

Attachment #9234157 - Flags: review?(iann_bugzilla)
Attachment #9234157 - Flags: review+
Attachment #9234157 - Flags: approval-comm-release?
Attachment #9234157 - Flags: approval-comm-release+
Attachment #9234157 - Flags: approval-comm-esr60?
Attachment #9234157 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/b24f9863858e
Port |Bug 462681 - mailWindowOverlay.js style/whitespace/indention/comment/linewrap cleanup. And some function simplifications| to SeaMonkey. r=frg
https://hg.mozilla.org/comm-central/rev/ae9a0e80b346
Lint mailWindowOverlay.js. r=IanN

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED

Patch 2 v1.1 (as rebased and checked in) with 3 more misindented functions (4 spaces) manually corrected. Carrying forward r/a+

Attachment #9234157 - Attachment is obsolete: true
Attachment #9234330 - Flags: review+
Attachment #9234330 - Flags: approval-comm-release+
Attachment #9234330 - Flags: approval-comm-esr60+
Whiteboard: SM2.53.9
Target Milestone: --- → seamonkey 2.89

https://gitlab.com/seamonkey-project/seamonkey-2.53-comm/-/commit/4c922c7d044eeafb77cf8de6e2045dfc3a763098
Port |Bug 462681 - mailWindowOverlay.js style/whitespace/indention/comment/linewrap cleanup. And some function simplifications| to SeaMonkey. r=frg a=frg
https://gitlab.com/seamonkey-project/seamonkey-2.53-comm/-/commit/fbb1b073abac97b7196ba1754250432c1df23fca
Lint mailWindowOverlay.js. r=IanN a=IanN

You need to log in before you can comment on or make changes to this bug.