Closed Bug 1703141 Opened 6 months ago Closed 6 months ago

frozen browser (100% cpu) on transition with a hover

Categories

(Core :: Graphics: WebRender, defect)

Firefox 89
defect

Tracking

()

VERIFIED FIXED
89 Branch
Tracking Status
firefox-esr78 --- disabled
firefox87 --- wontfix
firefox88 --- verified
firefox89 --- verified

People

(Reporter: karlcow, Assigned: nical)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

This is a serious bug.
https://twitter.com/tobiasbu/status/1378131506661560322

  1. Go to https://codepen.io/tobias_buschor/pen/ExZmygP
  2. Hover

Expected:
Look at the animation

Actual:
Animation starts then freezes the full browser with a maxed out CPU.

You need to force restart the browser to be able to use it.

Running mozregression gives this range
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=ff1a0c64ae96ab64fd2a88b23a24b9cf0e53fe2e&tochange=1b9d508de57519880036fdf48473d007f1c31e0a

tested on macos

Though it's strange because Bug 1516056 is just a comment change.
Or did I miss something in the regression range or the crash is random?

The other changeset in the range might be a problem? https://hg.mozilla.org/integration/autoland/rev/1b9d508de57519880036fdf48473d007f1c31e0a, this has mac specific changes.

Could someone run a regression window on Windows just to see if it's macos only?

No longer regressed by: 1516056
Component: Panning and Zooming → Graphics: WebRender
Flags: needinfo?(nical.bugzilla)
Blocks: gfx-triage
Assignee: nobody → nical.bugzilla
Status: NEW → ASSIGNED
Flags: needinfo?(nical.bugzilla)
Pushed by nsilva@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cbd0383b5719
WIP: Bug 1703141 - Prevent infinite loop in gradient fast-path. r=gfx-reviewers,lsalzman
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch

Please nominate this for Beta approval.

Flags: needinfo?(nical.bugzilla)

Comment on attachment 9214024 [details]
WIP: Bug 1703141 - Prevent infinite loop in gradient fast-path.

Beta/Release Uplift Approval Request

  • User impact if declined: infinite loop causing freezes
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Simple fix.
  • String changes made/needed: None.
Flags: needinfo?(nical.bugzilla)
Attachment #9214024 - Flags: approval-mozilla-beta?

Comment on attachment 9214024 [details]
WIP: Bug 1703141 - Prevent infinite loop in gradient fast-path.

Approved for 88.0b9, thanks. Can we land a crashtest for this?

Flags: needinfo?(nical.bugzilla)
Attachment #9214024 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
Flags: needinfo?(nical.bugzilla)

I was able to reproduce the issue on Firefox 89.0a1 (2021-04-05) under macOS 11.2.3 by using the links from Comment 0.

The issue is fixed on Firefox 88.0b9 and Firefox Nightly 89.0a1 (2021-04-11). Tests were performed on macOS 11.2.3, Windows 10 and Ubuntu 20.04.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
No longer blocks: gfx-triage
Pushed by nsilva@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/abe8316b5a90
Add a crash test. r=gfx-reviewers,lsalzman
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.