Closed Bug 1703147 Opened 6 months ago Closed 5 months ago

Site permissions panel overlaps the bottom of the button when proton is enabled

Categories

(Firefox :: Site Permissions, defect, P2)

Firefox 89
defect

Tracking

()

RESOLVED DUPLICATE of bug 1696500
Tracking Status
firefox-esr78 --- unaffected
firefox87 --- unaffected
firefox88 --- disabled
firefox89 --- affected

People

(Reporter: tduzan, Assigned: mhowell)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-door-hangers] [priority:2a])

Attachments

(1 obsolete file)

Noted this during my PM review. Saw this on Windows 10 w/ Light Theme and on macOS w/ Dark Theme.

When you open the site permissions panel, it is correctly aligned left/right, but the top left edge of the panel overlaps the bottom edge and a little bit more of the button in the address bar, and instead should be aligned against its bottom edge.

Priority: -- → P2
Whiteboard: [proton-door-hangers][priority:2a]

I can't seem to be able to reproduce this issue. Can you please provide an image/screencast with the issue?
Thank you.

Flags: needinfo?(tduzan)

I also see this on Linux (Dark Theme). It's very subtle.

Whiteboard: [proton-door-hangers][priority:2a] → [proton-door-hangers] [priority:2a]
Assignee: nobody → mhowell
Status: NEW → ASSIGNED

I addressed the needinfo request via Slack today with Molly Howell. Going to clear the needinfo flag, please tag me again if there are further questions. Thanks :)

Flags: needinfo?(tduzan)
Attachment #9218408 - Attachment is obsolete: true

The issue here was being caused by the light theme panel border appearing to overlap the button because the border was transparent. Bug 1696500 has changed that to a solid color, which means this bug no longer happens. I've run a screenshot by :tduzan, who agreed it looks good now.

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1696500
You need to log in before you can comment on or make changes to this bug.