Bookmarks function crashes system

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: mayer, Assigned: bugs)

Tracking

({crash})

Trunk
PowerPC
Mac System 9.x
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Accessing bookmarks at all, that is, simply clicking "Bookmarks" on the menu
bar, crashes my entire system, requiring reboot, within two to three clicks
invariably. The effect is similar to the "Scrolling Vertically Crashes System"
bug, and I DO have a Mac G3 Blue&White with an ATI card. I have installed ATI's
new (June) driver, created a new profile, and reduced my colors to thousands; no
good. Running Mozilla 1.1 (no build #, apparently). Usually the first click on
Bookmarks" does not cause a crash, though the menu is very slow to open, often
not opening until I have taken my finger off the mouse button, whereupon it will
flicker. Usually, the next click causes the crash. 

I have listed this as a Blocker, but I am able to use the mail function with no
apparent problems (also, no Scrolling Vertically problem in mail). I've started
using Opera for browsing.

BTW, I am running the SETI "screensaver;" earlier versions of it caused me
problems, but I'm not aware of any with the current version. Still, thought I'd
mention it.

Didn't find this in Frequently Reported Bugs nor in Bug Descriptions, searching
under Bookmarks, so here it is.

Comment 1

16 years ago
John, could you look under Help->About Mozilla.  The build number should be 
listed there (Gecko/2002xxxx).

Could you try to reproduce this bug with a talkback build, and supply the 
talkback id to this bug?  

Also, can you reproduce this bug with a new profile?

Thanks

Updated

16 years ago
Keywords: crash, stackwanted

Comment 2

16 years ago
(Chris, all Mac builds include TalkBack these days. Also, he said he's running 1.1, which doesn't 
display a build ID.)

John, please retest using a more recent build such as 1.2a or a current nightly build. Does 
TalkBack ever run after these crashes? (You do have it enabled, I hope.)
Severity: blocker → critical
(Reporter)

Comment 3

16 years ago
>sigh< My previous attempt to respond was delayed by a renewed issue with the Scrolling Vertically Crashes System bug. 

Downloaded Build 2002092903. Installed with yet another profile (which I named YA-Profile). Bookmarks worked fine until I copied my bookmark file from my old profile (by the way, I have a LOT of bookmarks, which I've been accumulating since Netscape 2.x). After relaunching Mozilla, the entire bookmark menu opened once and scrolled ALL THE WAY to the bottom of the list, but when I clicked on one of the bookmards near the bottom, nothing happened. Upon trying again, my system crashed. When I restarted and relaunched Mozilla to file this report, upon scrolling down to review the comments of others, my system crashed. I am filing this report via Opera. Mozilla mail, btw, works fine.

Points that may, or may not be of interest: my bookmark file is 312k. My mail folder is 221.4 megs. My XUL fastload file is 2.2 megs. My Mozilla memory allocation is 28672k (I don't know if that's the default, or if Mozilla adopted the preferences of the previous version). Curiously, when I set my computer (Mac OS 9.2) to calculate folder sizes in my profile folder, it froze for a period of time as though choking on the task, something it doesn't do even when I have it calculate folders for an entire hard drive. I was unable, though, to reproduce that effect. I have 576 megs of ram; virtual memory is enabled at 577 megs. 

Yes, I have Talkback enabled. Look for a report file with the word "Bookmarks" with varying numbers of exclamation marks and a great deal of cursing. 

Comment 4

16 years ago
John, what is the ID of the particular TalkBack report? (Also, I recommend
refraining from cursing.)
(Reporter)

Comment 5

16 years ago
The last one was TB11746713M. {Dammit, the built in Mac Copy-Paste function
isn't working, too. Had to type that in by hand, which makes error more likely.
But I think it's right.}

Oops, sorry about that cursing, but a man has his limits. Most of my cursing was
actually in the form of illegal characters, but you know what I really meant.

There seem to be a half dozen or so discreet talkback files (at least I trust
they're being discreet; a lot of things about my computer I wouldn't want being
talked back about). If you want other reports I'll half to try to track them
down and figure out which is which.

[I see Opera does strange things to text wrapping in Mozilla. I don't know how
to fix it; maybe one of you does. Just realized I absentmindedly used Mozilla to
paste this; no scrollling crash so far. Now, if I can just scroll down to the
commit button without bringing my computer down…  ]
Whiteboard: TB11746713M

Comment 6

16 years ago
Incident #11746713
-------------------
Product ID  MozillaTrunk
Build ID 2002092903
Operating System MacOS version 9.2.1
User Comments Well, it crashed my system two times in a row. First time: opening
bookmarks after copying them over from my old profile to my new one. Second
time: scrollin vertically.

Stack Trace
0x3f91ff54
CollectionsLib + 0x4c (0x3f921e3c)
MenusLib + 0x4f9c (0x3fa7442c)
MenusLib + 0x611c (0x3fa755ac)
InterfaceLib + 0x1a660 (0xffd0b6d0)
nsMenu::RemoveAll() [nsMenu.cpp, line 489]
nsMenu::MenuSelected() [nsMenu.cpp, line 725]
nsBuildMenu() [nsDynamicMDEF.cpp, line 417]
nsDoMagic() [nsDynamicMDEF.cpp, line 383]
nsDynamicSizeTheMenu() [nsDynamicMDEF.cpp, line 336]
nsDynamicMDEFMain() [nsDynamicMDEF.cpp, line 273]
MixedMode + 0x11bc (0xffcec2dc) 
Keywords: stackwanted
Whiteboard: TB11746713M

Comment 7

16 years ago
Worksforme, Mozilla 1.3 alpha, 2002121308, Windows 98. Reporter, can you
download and install Mozilla 1.3 alpha or later and try it again? Please also
test it with a fresh profile.

Comment 8

16 years ago
1 month with no response: resolving as WFM

Please reopen if problem persists after a clean install of a new build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.