Closed Bug 1703351 Opened 2 months ago Closed 3 days ago

Fix test_scroll_background_tabs in browser_scrollPositions.js when browser_scrollPositions_sample.html is loaded over httpS and not http

Categories

(Firefox :: Session Restore, defect)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1709136
Fission Milestone M8

People

(Reporter: annyG, Assigned: annyG)

References

(Blocks 1 open bug)

Details

No description provided.

This may be bad if it happens outside of tests as well.

To summarize what the test does:

  1. Opens a new window and adds a background tab.
  2. Loads an https URL in that background tab and scrolls the document to some position (say A).
  3. Navigates the background tab to an http URL and scrolls it to some other position (say B).
  4. Closes the tab and restores it.
  5. Checks that the restored tab is scrolled to position B.
  6. Goes back and checks that the tab is scrolled to position A.

Anny says this repros both with and without the patches from bug 1698601. It's unclear if this is actually caused by the https->http restore or navigations.

No longer depends on: 1698601
See Also: → 1698601

NI for Anny since she's looking into the same test in bug 1701735

Flags: needinfo?(agakhokidze)
Assignee: nobody → agakhokidze
Status: NEW → ASSIGNED
Flags: needinfo?(agakhokidze)
Fission Milestone: --- → M8

This is expected to be fixed with the fix for bug 1709136.

Depends on: 1698601
See Also: 1698601
No longer depends on: 1698601
See Also: → 1698601
Depends on: 1709136
Status: ASSIGNED → RESOLVED
Closed: 3 days ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1709136
You need to log in before you can comment on or make changes to this bug.