Closed Bug 170341 Opened 22 years ago Closed 19 years ago

Marquee printing problems

Categories

(Core :: Printing: Output, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: ji, Assigned: martijn.martijn)

References

()

Details

(Keywords: embed, topembed-, Whiteboard: [adt3])

Attachments

(3 files, 5 obsolete files)

Rolling text is not printed out.
Also the following problem might be related to marquee:
Print results of a web page containing marquee doesn't fit to the paper zise.
It's much more narrow and hard to read. The user needs to go to File | Page
Setup window to uncheck the ShrinkToFit checkbox. Maybe it's bacause for
printing, marquee is recogzied a long text string w/o line break and the web
page is considered as a much wider page? 

Steps to reproduce:
1. Go to http://www.sina.com.cn
2. Select File | Page Setup, make sure the ShrinkToFit checkbox is checked.
(it's  turned on by default)
3. Print out the page, observe the marquee text. You can see the printing result
doesn't fit to the page size and marquee is not printed out.
4. Use a build which doesn't have marquee support, like Netscape 
PR1 build, size fit problem doesn't exist.
need reduced test case (english please, I can't render the fonts with the url)
Keywords: qawanted, testcase
Attached file Testcase
*** Bug 170130 has been marked as a duplicate of this bug. ***
<marquee> will not be printed, read the last line of html.css
FYI, marquee can be printed out on IE.
The size fit problem is more serious than the marquee text print. On our
embedder application, there is no UI to control the ShrinkToFix setting, and the
setting is turned on by default. So on embedder application, the printouts are
coming out in very tiny text.
Keywords: qawantedtopembed
ji@netscape.com wrote:
> there is no UI to control the ShrinkToFix setting, and the
> setting is turned on by default. So on embedder application, the printouts are
> coming out in very tiny text.

Really ? AFAIK "ShrinkToFit" os broken on "trunk" and does not work in most
cases...
s/os broken/is broken/
The embedder application is based on mozilla 1.0.2 branch.
Yes, you are right, ShrinkToFit checkbox doesn't seem to be working on 9/20 trunk.
I can help out with printing issues, but it appears it was created to NOT print.
Assignee: rods → doron
Found a French web page containing marquee. This doesn't require Chinese fonts. :-)
http://www.mediametrie.fr/tv/index.html
Same problem happens when printing out this page: need to uncheck ShrintToFit
option for better printouts.
Yahoo China page (http://www.yahoo.com.cn) which doesn't contain marquee doesn't
have this size problem.
Marquee not beeing printed or shown in print preview is bug #163023 (even tough
it have been renamed to something stupid).
Marking this as topembed-/embed, as this is not currently stopping an embedding
customer.
Keywords: topembedembed, topembed-
Whiteboard: [adt3]
I think this bug suffers from bug 119078.
-moz-binding:none should make the text visible in print preview, but it does not.
The margin: 0 100% rule seems still applied, even with -moz-binding:none.
Depends on: 119078
Attached patch patch (obsolete) — Splinter Review
This makes marquee printable/visible on print preview.
I know it's a hack, but maybe worth considering?
Attachment #187634 - Flags: review?(bzbarsky)
Martijn, would it perhaps make more sense to use a scoped stylesheet with an
"@media print" rules in it to accomplish a simialr effect?  The ua.css approach
does sort of work, I guess, but the other would be cleaner...
Attached patch patch2a (obsolete) — Splinter Review
Something like this?
I couldn't get paged.css included in this patch, since cvsdo doesn't work in my
setup.
Attached patch patch2b (obsolete) — Splinter Review
the paged.css file.
No, I meant a scoped sheet in the XBL binding (so it doesn't affect perf on any
pages that don't use marquee).  See
http://lxr.mozilla.org/seamonkey/source/xpfe/components/autocomplete/resources/content/autocomplete.xml#11
for an example.
Attached patch patch3a (obsolete) — Splinter Review
So, something appr. like this?
Attachment #187634 - Attachment is obsolete: true
Attachment #189105 - Attachment is obsolete: true
Attachment #189106 - Attachment is obsolete: true
Attached patch patch3b (obsolete) — Splinter Review
I've also added padding: 0 !important; , because that makes the vertical
marquees visible on print preview.
Attachment #187634 - Flags: review?(bzbarsky)
Martijn, that last patch looks pretty reasonable.  Let me know when you want
review on it, ok?
Attachment #189205 - Flags: review?(bzbarsky)
Attachment #189207 - Flags: review?(bzbarsky)
Comment on attachment 189205 [details] [diff] [review]
patch3a

>Index: layout/style/html.css

> /* PRINT ONLY rules follow */
> @media print {
> 
>-  marquee { -moz-binding: none; }

We probably want to leave this part here...

With that, r+sr=bzbarsky
Attachment #189205 - Flags: superreview+
Attachment #189205 - Flags: review?(bzbarsky)
Attachment #189205 - Flags: review+
Comment on attachment 189207 [details] [diff] [review]
patch3b

>+/* PRINT ONLY rules follow */
>+@media print {
>+
>+  marquee { -moz-binding: none; }

That makes little sense in the binding's scoped sheet; take it out, please?

r+sr=bzbarsky with that.
Attachment #189207 - Flags: superreview+
Attachment #189207 - Flags: review?(bzbarsky)
Attachment #189207 - Flags: review+
(In reply to comment #25)
> That makes little sense in the binding's scoped sheet; take it out, please?
But shouldn't that work, then? You can disable a binding from inside a binding's
scoped stylesheet, not?
But I'll be happy to revert that change. I'll attach new patches.
Attached patch patch4aSplinter Review
patch4a, addressing Boris comments.
Attachment #189205 - Attachment is obsolete: true
Attached patch patch4bSplinter Review
patch4b, addressing Boris' comments.
Attachment #189330 - Attachment is obsolete: true
> But shouldn't that work, then? You can disable a binding from inside a
> binding's scoped stylesheet, not?

Not the way we have it implemented, actually...  Or rather, behavior would be
pretty undefined (sometimes the binding would be there, other times not, it
would be timing dependent, etc).
Attachment #189330 - Attachment is obsolete: false
Attachment #189207 - Attachment is obsolete: true
Martijn, you may want to request approval on those... ;)
Comment on attachment 189330 [details] [diff] [review]
patch4a

Fixes marquee printing problems, is very safe.
Comment on attachment 189330 [details] [diff] [review]
patch4a

Fixes marquee printing problems, is very safe.
Attachment #189330 - Flags: approval1.8b4?
Comment on attachment 189331 [details] [diff] [review]
patch4b

Part of the previous patch.
Attachment #189331 - Flags: approval1.8b4?
Attachment #189330 - Flags: approval1.8b4? → approval1.8b4+
Attachment #189331 - Flags: approval1.8b4? → approval1.8b4+
Ok, this is ready to be checked in.
Assignee: doronr → martijn.martijn
Fixed.
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: