Closed Bug 1703582 Opened 8 months ago Closed 6 months ago

Learn more hyperlink missing from plugin-crashed infobar

Categories

(Core :: Plug-ins, defect, P3)

Unspecified
All
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox-esr78 --- unaffected
firefox87 --- wontfix
firefox88 --- wontfix
firefox89 --- wontfix

People

(Reporter: peter.magyari, Unassigned)

References

(Blocks 2 open bugs, Regression)

Details

(Keywords: regression, Whiteboard: [proton-infobars] [priority:2b])

Affected platforms:
All

Steps to reproduce:

  1. Launch Firefox
  2. Navigate to this link
  3. Start playing the video on the page
  4. In a new tab, navigate to about:config and add the following pref as boolean and set it to true: "media.gmp.plugin.crash"
  5. To back to the tab from Step 2

Expected result:
The plug-in crashed infobar is triggered and has a "learn more" hyperlink

Actual result:
The plug-in crashed infobar is triggered but it has no "learn more" hyperlink

Notes
The issue is reproducible all the way back to Nightly 82.0a1 since it is a regression from Bug 1660608
This issue occurs with both Proton set to on/off

Priority: -- → P2
Whiteboard: [proton-infobars] → [proton-infobars] [priority:2b]

The

notification.messageText.appendChild(new Text(" "));

call at https://searchfox.org/mozilla-central/rev/5a8487d8e9dd114289083800f723d9c56c9a8003/browser/actors/PluginParent.jsm#212

produces

NS_ERROR_FAILURE

with no message (ugh). I have no idea why off-hand. The regression window appears incorrect, because the 2020-08-25 nightly still has a "Learn more" text. Peter, can you re-check? I suspect bug 1661043 which landed a few days later.

Flags: needinfo?(peter.magyari)

Romain, this predates proton by 6 months, does it really need to be P2b?

Flags: needinfo?(rtestard)
No longer regressed by: 1660608

AGreed that given this is not a proton regression it should not be prioritized over proton polish items. Marking a P3

Flags: needinfo?(rtestard)
Priority: P2 → P3
Flags: needinfo?(peter.magyari)
Regressed by: 1661043
Resolving as wont fix, plugin support deprecated in Firefox 85.
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.