Closed Bug 1703588 Opened 8 months ago Closed 8 months ago

FxA toolbar monogram avatar is barely visible while using the browser light theme

Categories

(Firefox :: Toolbars and Customization, defect)

Desktop
All
defect

Tracking

()

RESOLVED FIXED
89 Branch
Tracking Status
firefox87 --- unaffected
firefox88 --- affected
firefox89 --- affected

People

(Reporter: alin.ilea, Assigned: dcoates)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-icons])

Attachments

(1 file)

Attached video 2021-04-07_16h34_29.mp4

Tested with:

Release 87
Beta 88.0b8
Nightly 89.0a1 (2021-04-07)

Tested on:

Windows 10

Preconditions:

Set up the following prefs in about:config:

Steps:

  1. Launch firefox and sign in to FxA.
  2. Change the browser theme to Light.
  3. Click on the FxA toolbar avatar.

Actual result:

The FxA toolbar monogram avatar is barely visible while browser light theme is applied (see the video recording attached).

Expected result:

The FxA toolbar monogram avatar should remains visible.

Note 1: This is not reproducible with context-fill enabled.
Note 2: This is not reproducible in Release 87.

Since 87 is not affected I tried to perform the mozregression and I got the following regression range:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=e90eebb4095d3fdd9c8b07bf22795eee7c3e9ed6&tochange=c6783cb12c2c5fc5739ed6496d1f3b560dcc091b

Bug 1698499 or bug 1698416 are the most likely candidates.

I think what we might want to do here is land bug 1699892, and try to get it uplifted if possible. If we can't get it uplifted, then we might want to delay shipping the default avatars, unless Product is okay with a hard-to-see avatar in Light theme.

Let me see if I can get a patch for bug 1699892 put together.

Inverting the dependency, since bug 1699892 seems to fix this.

No longer blocks: 1699892
Depends on: 1699892

Now that bug 1699892 is fixed in Nightly, can you confirm on your end that the issue no longer persists?

Flags: needinfo?(alin.ilea)

Hi Mike,
Yes, I can confirm that the issue is no longer reproducible in latest Nightly 89.0a1 (2021-04-08).
Thanks!

Flags: needinfo?(alin.ilea)

Resolving per the comments. :-)

Assignee: nobody → dcoates
Status: NEW → RESOLVED
Closed: 8 months ago
OS: Unspecified → All
Hardware: Unspecified → Desktop
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch
Blocks: proton-icons
Whiteboard: [proton-icons]
You need to log in before you can comment on or make changes to this bug.