Closed Bug 1703625 Opened 8 months ago Closed 8 months ago

Firefox Profiler toolbar button's menu has unreadable dark text on dark background with browser.proton.contextmenus.enabled and Dark theme enabled

Categories

(DevTools :: Performance Tools (Profiler/Timeline), defect, P2)

Desktop
Windows
defect

Tracking

(firefox-esr78 unaffected, firefox87 disabled, firefox88 disabled, firefox89 verified)

VERIFIED FIXED
89 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox87 --- disabled
firefox88 --- disabled
firefox89 --- verified

People

(Reporter: cpeterson, Assigned: itiel_yn8)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression, Whiteboard: [proton-context-menus] [priority:2a])

Attachments

(2 files)

Steps to reproduce

  1. Set browser.proton.contextmenus.enabled pref = true.
  2. In about:addons, change the Firefox theme to "Dark" ("A theme with a dark color scheme.").
  3. Load https://profiler.firefox.com/
  4. Click the "Enable Profiler Menu Button" button.
  5. Click the profiler toolbar button's down arrow to expand the profiler menu.
  6. Expand the profiler menu's "Settings" drop-down list.

Expected result

The list of profiler settings should be readable.

Actual result

The list is unreadable because the setting names are dark text on a dark background color. See the attached screenshot.

I bisected this regression to this pushlog for bug 1682522:

https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=bf6cf886b9683288fa453a66f999875b6ff6d3eb&tochange=a1f8152b4981d05ae1f5edaa5cb2035e20d38564

Summary: Firefox Profiler toolbar button's menu has unreadable dark text on dark background with browser.proton.contextmenus.enabled → Firefox Profiler toolbar button's menu has unreadable dark text on dark background with browser.proton.contextmenus.enabled and Dark theme enabled
Component: Themes → Gecko Profiler
Product: Toolkit → Core
Hardware: Unspecified → Desktop
Whiteboard: [proton-context-menus]
Component: Gecko Profiler → Performance Tools (Profiler/Timeline)
Product: Core → DevTools
Priority: -- → P2
Whiteboard: [proton-context-menus] → [proton-context-menus] [priority:2a]

:nchevobbe: To repro on windows, macos looks fine.

Flags: needinfo?(nchevobbe)

I can confirm on windows

Flags: needinfo?(nchevobbe)
Assignee: nobody → itiel_yn8
Status: NEW → ASSIGNED

We also have some dark-mode specific styling already: https://searchfox.org/mozilla-central/rev/21110f35dbb95d3c41c8c5bd363ec689900af30f/browser/themes/shared/customizableui/panelUI.inc.css#2673-2678

We can also decide to remove all specific styling that we added at the time. The goal was to make the select box more subtle, without borders, but this makes it necessary to maintain all this specific code.

Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2c98246c66c5
Fix the Profiler popup menulist styles for Proton r=mconley
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch

Reproduced the initial issue on Profiler using old Nightly from 2021-04-07, verified that this is fixed in latest Nightly 89.0a1.

Status: RESOLVED → VERIFIED
See Also: → 1702292
You need to log in before you can comment on or make changes to this bug.