page up/page down (pgup/pgdn) in form input text box should scroll page, not move cursor

VERIFIED DUPLICATE of bug 27771

Status

()

Core
Layout: Form Controls
VERIFIED DUPLICATE of bug 27771
15 years ago
15 years ago

People

(Reporter: Keith Lea, Assigned: John Keiser (jkeiser))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPME)

(Reporter)

Description

15 years ago
the summary says it all. i hate having to use the mouse or tab when i want to
move a page down after inputting something in a text box.

Comment 1

15 years ago
What if someone said 'I hate RFEs'?

if you don't like this binding then you're free to experminent with removing it.
http://www.mozilla.org/unix/customizing.html#key_example
Whiteboard: DONTFIX
(Reporter)

Comment 2

15 years ago
why would anyone want pgdn to move the cursor to the end of the line? that's
what end is for.

Comment 3

15 years ago
I have no idea.  But this is a dup of a really old bug (don't have the number
offhand, sorry) that single-line text controls shouldn't steal an event that
they can't handle usefully, and should let the event bubble up to the containing
page.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: DONTFIX → DUPME

Comment 4

15 years ago
CC sairuh in case she knows the number of the older bug covering this.
i couldn't quite a bug that matches this one. bug 130380 sounds similar, but not
quite. perhaps kathy might know?

Comment 6

15 years ago
bug 130380 is urlbar specific; that isn't the right one for this bug
I think 27771 is

*** This bug has been marked as a duplicate of 27771 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
thanks, kathy!

v.
Status: RESOLVED → VERIFIED

Comment 8

15 years ago
Yes, that's the one I was thinking of.  Thanks, Kathy!
You need to log in before you can comment on or make changes to this bug.