Closed Bug 17037 Opened 20 years ago Closed 20 years ago

{css-moz} Font size on a button doesn't work

Categories

(Core :: Layout: Form Controls, defect, P3)

x86
Windows 98
defect

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: marshall, Assigned: eric)

References

Details

(Keywords: css-moz)

I'm not 100% this is a bug or just my bad coding.  But the font size works on
text in a span but not on a button - I believe it did at one time.

Here is a simple example:

<html>
 <head>
  <style>
   #right { font-size: 8pt; }
  </style>
 </head>
 <body>
  <span id="right">working pt</span>
  <form>
   <INPUT type="button" value="Not working pt" id="right">
  </form>
 </body>
</html>
*** Bug 17038 has been marked as a duplicate of this bug. ***
Assignee: karnaze → rods
Reassigning to Rod.
If :-moz-buttonlabel is a pseudo-element, then the problem is likely the design
of html.css.  Some of the declarations in rules with selector
input[type=button]:-moz-buttonlabel
should instead be given the selector
input[type=button]

However, if -moz-buttonlabel is a pseudoclass, then this won't help.
Assignee: rods → evaughan
Status: NEW → ASSIGNED
QA Contact update.
Target Milestone: M15
targetting as p3 for m15
Summary: Font size on a button doesn't work → {css-moz} Font size on a button doesn't work
Whiteboard: (py8ieh: check html.css)
Keywords: css-moz
Severity: normal → critical
Setting severity to critical
Okay, probing a little deeper on this, I found that the font-size on a button
does actually work, but the default font for a button is apparently different
than the default font for the browser.  This caused a perception problem since
not all fonts are created equal in size (a 12pt helvetica is not the same size
as a 12pt times).  After modifying the original testcase to change the font to
6pt and set up a "with" and "without" style setting for both span and button, I
discovered the size does in fact change *and* that's when I noticed they were
two different fonts.

Marking WORKSFORME on:
- Win98 2000-01-25-20 Commercial build
- Linux6 2000-01-25-20 Commercial build
- MacOS86 2000-01-26-03 Commercial build
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
Severity: critical → normal
Whiteboard: (py8ieh: check html.css)
Updating QA contact.
QA Contact: ckritzer → bsharma
Verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.